WordPress.org

Make WordPress Core

Opened 12 months ago

Last modified 12 months ago

#48686 new defect (bug)

Page white-only after pressing Update, but update done

Reported by: aclassifier Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 5.3
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

When I press the Update button the page is sent and updated, but the page goes white and stays white. Not "forever".

Safari 13.0.2 with macOS 10.14.6 Mojave and same with Safari 13.0.3 with macOS 10.13.6 High Sierra.

Change History (6)

#1 @nielslange
12 months ago

@aclassifier: Does this issue happen when you update the core version, a theme, a plugin or a page or a post?

#2 @SergeyBiryukov
12 months ago

  • Component changed from General to Editor

#3 @SergeyBiryukov
12 months ago

  • Keywords reporter-feedback added; dev-feedback removed

Hi there, welcome to WordPress Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Twenty) activated?

#4 @aclassifier
12 months ago

This morning all was back to normal! It updates both after Page and Post Update.

But yesterday I was struggling with a problem where I was not able to log in. A summary of that is at my blog, https://www.teigfam.net/oyvind/home/publishing/061-wordpress/#wordpress_53_big_image_2560_threshold_not_wanted. I tried to solve that, first by disabling all plugins (did not help), and enabling them again (also did not help). Restoring Jetpack was not that easy, there was a lot of buttons to press and having it see ssl again. But it stopped complaining at some point when I pleased it. (That's how it feels). More below. I kept TwentyTwelve all the time. But I was still not able to log in, but did get an error message pointing to functions.php: I then went in via ftp and restored to my old TwentyTwelveChild functions.php, effectively not seeing this line any more:

<?php add_filter( 'big_image_size_threshold', '__return_false' );?>

But this may be another problem. The white screen after Update was there before I started with the add_filter matter that messed it all up with not being able to log in. But even this was after some time. The not filtering large file was indeed working with that code line for some time!

Another matter, which I guess adds even more smoke: My WordPress runs on one.com. I had been there to see which PHP was running, because of this update problem. It had the "latest stable" which is 7.3. At some point I told it to use 7.4 which it called "beta" and then after some minutes I could not see any change, so I went back to 7.3 again. It is set to update automatically when 7.4 becomes "stable".

Both my own teigfam.net and wordpress. com and wordpress.org have had all infocapsules available for them all the time.

Now I don't have any secrets, but I may have smoked this too much. As a programmer myself I have no clue what might have caused this to have become fixed. Right now it seemed like it was fixed by itself over night. Which is when I used to laugh by myself. No magic here, but almost.

Appendix

Plugins that I deactivated and reactivated:

Akismet Anti-Spam, All in one Favicon, Category to Pages WUD, Classic Editor, Collapse-O-Matic, Disable "BIG image" Threshold, Easy Code Manager, Jetpack by WordPress.com, Page Excerpt, Page Specific Menu Items, PDF Embedder, Really Simple SSL (even if I use .htaccess), Simple Share Buttons Adder, Slideshow, Subscribe to Comments Reloaded, Table of Contents Plus, TablePress, UpdraftPlus - Backup/Restore PLUS Jetpack free version, SSL enabled.

My .htaccess file:

#Rewrite everything to https
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule (.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Last edited 12 months ago by aclassifier (previous) (diff)

#5 @aclassifier
12 months ago

It's partly back again, once only. There was a very long pause after the pressing of the Update button and it would not rewrite the screen. Then, when its fast back, it's with contents ok. But in all cases the Update updates the page in the data base. When I retry this with both Page and Post it always works. The one only case when I did get the no-rewrite screen was when I came back to the machine after 8 hours and Safari was still logged into WordPress. I did not get any timeout message telling me that I needed to log in again. It didn't, all the other cases worked fine. Could that be a thread to look for? Something with some part of the system thinking I was not logged in?

I guess that's new. But if you don't want these mood changes, please tell. Like if it would fail again tonight.

Here's a page I test with: https://www.teigfam.net/oyvind/home/publishing/061-wordpress/. I just update WordPress 5.3 = number

#6 @aclassifier
12 months ago

Last report from me, until there is an update of WordPress I guess.

It now repeats (has 5-10 times this morning) with not refreshing the screen after presssing the Update. Also, it is not rotating. And some times I see the Update button grayed out and in rotation. Opening another window and watching the result = all fine, data has arrived in DB, in all these cases.

Note: See TracTickets for help on using tickets.