WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 4 weeks ago

Last modified 4 weeks ago

#48707 closed defect (bug) (wontfix)

Heading can't start with a number followed by a dot

Reported by: bikegremlin Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Editor Keywords:
Focuses: Cc:

Description

I usually write article headings numerated, like:

  1. Introduction
  2. Point

2.1. Sub-point
etc.

With the WordPress 5.3. it is impossible to start a chapter with say:
1.

etc.

It automatically switches to numbered lists. Even though I had chosen the block to be H2, or H3 etc.

Change History (4)

#1 @SergeyBiryukov
13 months ago

  • Summary changed from Heading can't start with a nuber followed by a dot to Heading can't start with a number followed by a dot

#2 @bikegremlin
11 months ago

Workaround that has worked for me:

a) Write the chapter without space after the number. Like:

1.Chapter name

b) Press space after the number - "1." in this example.

c) It will instantly turn into a numbered list. NOW press backspace. It reverts to heading - tried with several WordPress installations, it gets the job done.

#3 follow-up: @noisysocks
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi @bikegremlin. The "1. " shortcut for creating a List block is by design. There are a few workarounds, including adding the Heading block first and then typing "1. Heading".

#4 in reply to: ↑ 3 @bikegremlin
4 weeks ago

Replying to noisysocks:

Hi @bikegremlin. The "1. " shortcut for creating a List block is by design. There are a few workarounds, including adding the Heading block first and then typing "1. Heading".

It hadn't worked properly, even when I would add a heading block.
However, seems to have been fixed - no longer auto-switching from heading, to a numbered list, if I start a heading with a number, like "1. Introduction".

So - as far as I can see - it's been fixed, works as it should now. :)

Note: See TracTickets for help on using tickets.