WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#48723 closed defect (bug) (duplicate)

Twenty Twenty: Editor Block Toolbar Icons “invisible” inside a block with background color preset

Reported by: collet Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords:
Focuses: ui, css Cc:

Description

To reproduce the issue:

  • In the customizer, set the Background Color as white (to generate colors)
  • In the editor, insert a group and set its background color to Primary using the color palette.
  • Insert a block (e.g. paragraph, heading...) inside the group

The icons of the block toolbar (when not set to Top Toolbar) are white instead of dark.

https://i.imgur.com/v3lTv1z.png

As soon as the background color in the customizer is different than default, the toolbar icons color is changed. For white text color, the icons are white thus invisible. For black text color, the icons are black instead of the Gutenberg dark gray.

Change History (4)

#1 @nielslange
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@collet Thanks for reporting this issue! This is very much appreciated. As this issue had already been reported in #48684, I'll close this issue for now.

#2 follow-up: @collet
4 months ago

@nielslange Thanks for the reply. My bad I didn't see it!

#3 @ianbelanger
4 months ago

Duplicate of #48684.

#4 in reply to: ↑ 2 @nielslange
4 months ago

@nielslange Thanks for the reply. My bad I didn't see it!

Don't worry, @collet !

Note: See TracTickets for help on using tickets.