WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4880 closed defect (bug) (invalid)

modrewrite weirdness with pingback

Reported by: matija Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: XML-RPC Keywords:
Focuses: Cc:

Description

i'm gonna describe my problem and solution i make:
i wrote a 'page' about something, doesn't matter, let's name it 'lookme'. this page was accesible via modrw url mydomain.com/lookme. after some time, i decided to migrate it to 'post'.
i rename page name and page slug, added -old at the end. new url/name is now mydomain.com/lookme-old. i rename it while i was copying data to new one, then i delete old 'page' so only the new 'post' exists.
since then, no pingback come to this post. i check server settings, xmlrpc.php, upgrade wp to 2.2.2, nothings happen. i go deeper in code, and i found, that function url_to_postid returns nothing, while in db, i still found 'lookme-old'.

solution that works for me: i deleted row from wp_options (rewrite_rules), and generate new one via admin > options > permalinks. now works fine.

problem, i think, or solution: should you delete 'old' rules if some page is deleted and recreate another one?
greetings

Change History (4)

comment:1 markjaquith7 years ago

I was not able to reproduce:

  1. Created page with slug "original-page"
  2. Published page
  3. Edited page, renamed slug to "new-page"
  4. Verified that rewrite_rules were updated

If you did any part of that manually (by manipulating the database) you shouldn't expect it to work. Could you explain the series of steps one must take to trigger the bug in a little more detail? Can you reproduce the bug now?

comment:2 matija7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

hm, i don't think that i was modifying db. but now i tested just like u said before. create page, edit page, rename page & slug, delete page ... check db, no record was there. strange. anyway, works now :)
thanks, greetings

comment:3 foolswisdom7 years ago

  • Milestone 2.4 (next) deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 foolswisdom7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.