Make WordPress Core

Opened 4 years ago

Closed 3 weeks ago

#48800 closed feature request (wontfix)

Twenty Twenty: Conditional loading of language/locale specific css and php files

Reported by: ianbelanger's profile ianbelanger Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: 2nd-opinion close
Focuses: Cc:

Description

First reported on GitHub by @nukaga

https://github.com/WordPress/twentytwenty/issues/970

In the current site design, the title is too large in Japanese and Chinese.
The center alignment is also extraordinary.

https://github.com/WordPress/twentytwenty/issues/118#issuecomment-541292567
https://github.com/WordPress/twentytwenty/issues/118#issuecomment-538964579

Solution
Is it possible to separate the title and body CSS in several languages?

Change History (3)

#1 in reply to: ↑ description @SergeyBiryukov
4 years ago

Replying to ianbelanger:

Is it possible to separate the title and body CSS in several languages?

It is possible, see the Typography section in Twenty Seventeen for example.

It is also possible to disable specific Google fonts for specific locales, see twentyseventeen_fonts_url() for example.

However, we should be careful not to create excessively verbose CSS, see #47925 and #45731 for Twenty Nineteen.

#2 @karmatosed
4 weeks ago

  • Keywords close added

Whilst it does seem that you can split the CSS my recommendation would be that we do not do this in an older default theme. I would suggest the fact that this hasn't had a patch yet also reflects the nature of it being one area could have further issues if explored, for example on disabling specific fonts.

As for my recommendation on where this ticket goes.

  • I would recommend to 'close' this with a 'won't fix'.
  • If someone does come up with a passive patch before closing that doesn't cause issues then absolutely we could consider adding.

I am basing this recommendation on the following:

  • We are focusing on bugs specifically for older default themes, this isn't a bug specifically just overly large text. It's not pretty but not a bug.
  • It could bring in more complications and issues than fix if create verbose CSS at this stage.

#3 @karmatosed
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I am going to now close this, we can always have a new ticket if needed. Thanks everyone.

Note: See TracTickets for help on using tickets.