WordPress.org

Make WordPress Core

Opened 5 days ago

Closed 4 days ago

#48852 closed defect (bug) (maybelater)

add exceptions for Class WP_Theme Theme name

Reported by: dkarfa Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords: has-patch
Focuses: Cc:
PR Number:

Description (last modified by SergeyBiryukov)

PHP 7.4 allow exceptions from __toString(), add exceptions for WP_Theme Class theme name

Attachments (1)

48852.patch (628 bytes) - added by dkarfa 5 days ago.

Download all attachments as: .zip

Change History (3)

@dkarfa
5 days ago

#1 @SergeyBiryukov
5 days ago

  • Description modified (diff)

#2 @SergeyBiryukov
4 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Thanks for the ticket!

As noted in comment:2:ticket:48848, WordPress still supports PHP 5.6+, so the patch cannot be used until the minimum required version is bumped to PHP 7.4.

It's also not quite clear what's the issue being addressed here, the existing code seems to work as intended.

Note: See TracTickets for help on using tickets.