WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#48884 closed defect (bug) (fixed)

Update WordPress packages with fixes targeted for 5.3.1

Reported by: youknowriad Owned by: SergeyBiryukov
Milestone: 5.3.1 Priority: normal
Severity: normal Version: 5.3
Component: Editor Keywords: has-patch commit
Focuses: Cc:

Description

Updated packages:

  • @wordpress/block-directory@1.0.6
  • @wordpress/block-editor@3.2.5
  • @wordpress/block-library@2.9.6
  • @wordpress/core-data@2.7.5
  • @wordpress/edit-post@3.8.6
  • @wordpress/editor@9.7.6
  • @wordpress/format-library@1.9.5

Attachments (2)

update-packages-5.3.1.diff (21.9 KB) - added by youknowriad 4 months ago.
48884-block-directory-1.0.6.diff (10.9 KB) - added by aduth 4 months ago.
Resolve block-directory to 1.0.6

Download all attachments as: .zip

Change History (12)

#1 @youknowriad
4 months ago

#48649 was marked as a duplicate.

#2 @SergeyBiryukov
4 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from assigned to closed

In 46860:

Block Editor: Bug fixes targeted for WordPress 5.3.1.

The list of included fixes:

Updated packages:

  • @wordpress/block-directory@1.0.6
  • @wordpress/block-editor@3.2.5
  • @wordpress/block-library@2.9.6
  • @wordpress/core-data@2.7.5
  • @wordpress/edit-post@3.8.6
  • @wordpress/editor@9.7.6
  • @wordpress/format-library@1.9.5

Props youknowriad, ellatrix, epiqueras, audrasjb, gziolo, mcsf, kyliesabra.
Fixes #48884.

#3 @SergeyBiryukov
4 months ago

In 46861:

Block Editor: Bug fixes targeted for WordPress 5.3.1.

The list of included fixes:

Updated packages:

  • @wordpress/block-directory@1.0.6
  • @wordpress/block-editor@3.2.5
  • @wordpress/block-library@2.9.6
  • @wordpress/core-data@2.7.5
  • @wordpress/edit-post@3.8.6
  • @wordpress/editor@9.7.6
  • @wordpress/format-library@1.9.5

Props youknowriad, ellatrix, epiqueras, audrasjb, gziolo, mcsf, kyliesabra.
Merges [46860] to the 5.3 branch.
Fixes #48884.

This ticket was mentioned in Slack in #core by sergey. View the logs.


4 months ago

#5 @aduth
4 months ago

In Slack, there were some errors reported which I believe to be related to this changeset.

In update-packages-5.3.1.diff, the changes in package-lock.json which resolve @wordpress/block-directory seem unexpected, since there's nothing which depends on block-directory@1.1.0, only at ^1.0.6. I'm not sure why it would suddenly start failing when using the latest version, but I expect it could be related to changes at Gutenberg#17576 (cc @gziolo).

In any case, when testing to see whether it helps to restore the resolved @wordpress/block-directory to an expected version (1.0.6), it appears to resolve the errors.

Last edited 4 months ago by aduth (previous) (diff)

#6 @aduth
4 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

@aduth
4 months ago

Resolve block-directory to 1.0.6

#7 @garrett-eclipse
4 months ago

  • Keywords commit added

Myself, @azaozz & @audrasjb confirmed via Slack the patch applies and fixes the issue.

#8 @SergeyBiryukov
4 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 46870:

Block Editor: Resolve @wordpress/block-directory to the expected version, 1.0.6.

Follow-up to [46860].

Props aduth, garrett-eclipse, audrasjb, azaozz.
Fixes #48884.

#9 @SergeyBiryukov
4 months ago

In 46871:

Block Editor: Resolve @wordpress/block-directory to the expected version, 1.0.6.

Follow-up to [46860].

Props aduth, garrett-eclipse, audrasjb, azaozz.
Merges [46870] to the 5.3 branch.
Fixes #48884.

#10 @gziolo
4 months ago

It's weird that @wordpress/block-directory@1.0.6 is not listed in the package.json in the first place. It would prevent this issue to be introduced.

I also think that we should consider using legacy tag for updated packages:
"@wordpress/block-editor": "3.2.5@legacy",
to avoid pulling in more recent packages.

Note: See TracTickets for help on using tickets.