WordPress.org

Make WordPress Core

Opened 6 weeks ago

Closed 6 weeks ago

#48912 closed enhancement (duplicate)

Twenty Twenty: Add Telegram to social media icons

Reported by: msaari Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.3
Component: Bundled Theme Keywords: has-patch has-screenshots
Focuses: Cc:
PR Number:

Description

It would be nice to have Telegram included in the list of social media icons. There are several plugins for Telegram integrations and the most popular one (https://wordpress.org/plugins/wptelegram/) has 10000+ active installations, so there's definitely some cross-over here.

I've taken the Telegram logo from Wikimedia Commons (https://upload.wikimedia.org/wikipedia/commons/8/82/Telegram_logo.svg) and created a Telegram icon out of it. It's a slightly simplified version of the logo that works better as a single color icon. Telegram uses the same simplified logo in their app icons.

I've linked the logo to Telegram.org, Telegram.me and T.me urls. That's what Telegram uses as far as I can tell.

Attachments (3)

class-twentytwenty-svg-icons.php.patch (548 bytes) - added by msaari 6 weeks ago.
Patch for twentytwenty/classes/class-twentytwenty-svg-icons.php
socialmediaicons.png (14.1 KB) - added by msaari 6 weeks ago.
The Telegram icon in use
telegram-app-icon.png (17.4 KB) - added by msaari 6 weeks ago.
The Telegram Mac OS app icon.

Download all attachments as: .zip

Change History (7)

@msaari
6 weeks ago

Patch for twentytwenty/classes/class-twentytwenty-svg-icons.php

@msaari
6 weeks ago

The Telegram icon in use

@msaari
6 weeks ago

The Telegram Mac OS app icon.

#1 @poena
6 weeks ago

Hi

Twenty Twenty uses the same social icons that will be available in the block editor.
For consistency, any new icons would need to be added there too.
https://github.com/WordPress/gutenberg/tree/master/packages/block-library/src/social-link

#2 @msaari
6 weeks ago

Good point about the block editor. I've made a pull request there as well: https://github.com/WordPress/gutenberg/pull/19000

#4 @ianbelanger
6 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #48905

Note: See TracTickets for help on using tickets.