WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 6 months ago

#48931 closed defect (bug) (fixed)

Align and size box in image widget issue

Reported by: fotisps Owned by: audrasjb
Milestone: 5.4 Priority: normal
Severity: normal Version: 5.3
Component: Widgets Keywords: has-screenshots has-patch commit
Focuses: ui Cc:

Description

The align box in Image Widget seems to overlap on size box and there is only the option of choosing the size of the image.

Attachments (4)

bug-display-settings-image.png (911.7 KB) - added by fotisps 8 months ago.
Capture d’écran 2020-01-11 à 23.03.23.png (291.4 KB) - added by audrasjb 7 months ago.
We need to "display:none" this element as well as the whole fielset is currently hidden in Widget context.
Capture d’écran 2020-01-11 à 23.07.39.png (226.6 KB) - added by audrasjb 7 months ago.
Widgets: hide unwanted fieldset legend from Widget Image media modal.
48931.diff (635 bytes) - added by audrasjb 7 months ago.
Widgets: hide unwanted fieldset legend from Widget Image media modal.

Download all attachments as: .zip

Change History (11)

#1 @marcelo2605
8 months ago

Hey @fotisps could you share some print of this error and how can I reproduce it?

#2 @marcelo2605
8 months ago

  • Keywords needs-screenshots added

#3 @marcelo2605
8 months ago

  • Keywords needs-screenshots removed

#4 @audrasjb
7 months ago

  • Component changed from General to Widgets
  • Keywords has-screenshots added
  • Owner set to audrasjb
  • Status changed from new to accepted

Hi @fotisps, welcome to WordPress Core Trac and thank you for opening this ticket!

I can reproduce the issue.
Moving to Widget component.

@audrasjb
7 months ago

We need to "display:none" this element as well as the whole fielset is currently hidden in Widget context.

@audrasjb
7 months ago

Widgets: hide unwanted fieldset legend from Widget Image media modal.

@audrasjb
7 months ago

Widgets: hide unwanted fieldset legend from Widget Image media modal.

#5 @audrasjb
7 months ago

  • Keywords has-patch commit added; needs-patch removed
  • Milestone changed from Awaiting Review to 5.4

In 48931.diff:

  • Widgets: hide unwanted fieldset legend from Widget Image media modal.

The patch is tested and works fine. It simply uses the CSS rule that is already used to hide other useless parts of the media modal (see screenshots above).

#6 @audrasjb
6 months ago

The patch still applies cleanly and is pretty straightforward.

Adding on the "quick wins" list for 5.4, and a commit keyword :)

#7 @SergeyBiryukov
6 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 47292:

Widgets: Hide the "Align" legend in Image Widget display settings, since the associated controls are also hidden.

Props audrasjb, fotisps, marcelo2605.
Fixes #48931.

Note: See TracTickets for help on using tickets.