Make WordPress Core

Opened 4 years ago

Closed 3 months ago

#48958 closed defect (bug) (duplicate)

Twenty Twenty: Multiple Block Left/Right Align Display Issues

Reported by: deepakvijayan's profile deepakvijayan Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

In Twenty Twenty theme, when adding multiple images left-aligned or right-aligned inside the content editor, the alignment is not correct on the front end.

All the images are placed one above the other, breaking the whole layout.

Attachments (5)

image_2019_12_13T05_51_03_913Z.png (260.3 KB) - added by deepakvijayan 4 years ago.
Content Editor: Images Left Aligned
image_2019_12_13T05_49_59_269Z.png (100.7 KB) - added by deepakvijayan 4 years ago.
Frontend Preview: Left Aligned Images
image_2019_12_13T05_51_42_199Z.png (285.2 KB) - added by deepakvijayan 4 years ago.
Content Editor: Images Right Aligned
image_2019_12_13T05_48_39_074Z.png (112.2 KB) - added by deepakvijayan 4 years ago.
Frontend Preview: Right Aligned Images
left-align-off-edge.jpg (73.0 KB) - added by joyously 4 years ago.
Related: left aligned gallery is cut off

Download all attachments as: .zip

Change History (9)

@deepakvijayan
4 years ago

Content Editor: Images Left Aligned

@deepakvijayan
4 years ago

Frontend Preview: Left Aligned Images

@deepakvijayan
4 years ago

Content Editor: Images Right Aligned

@deepakvijayan
4 years ago

Frontend Preview: Right Aligned Images

#1 @joyously
4 years ago

  • Component changed from Themes to Bundled Theme
  • Focuses ui removed
  • Keywords needs-patch added
  • Summary changed from Twenty Twenty Theme: Block Left/Right Align Display Issues to Twenty Twenty: Multiple Block Left/Right Align Display Issues

This ticket was mentioned in Slack in #core-themes by joyously. View the logs.


4 years ago

@joyously
4 years ago

Related: left aligned gallery is cut off

#3 @JarretC
4 years ago

Related: #48718

This is due to the elements being absolutely positioned. I haven't yet figured out a good workaround without removing the absolute positioning entirely and placing the images inside of the content "box" like the majority of other sites do that would fix this issue.

#4 @poena
3 months ago

  • Focuses css removed
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi
I am going to close this as a duplicate of #48718.

Note: See TracTickets for help on using tickets.