Make WordPress Core

Opened 23 months ago

Closed 23 months ago

Last modified 10 months ago

#48968 closed defect (bug) (reported-upstream)

hoverintent-js.min.js conflicted amp

Reported by: patkhonsiam Owned by: audrasjb
Milestone: Priority: normal
Severity: normal Version: 5.3.1
Component: Toolbar Keywords: has-screenshots
Focuses: Cc:



My web used plugin AMP (standard mode), and i have updated wordpress to Version 5.3.1
and found Invalid script


old version of hoverintent-js.min.js no problem

Thank you

Attachments (2)

wp-bug-01.jpg (496.6 KB) - added by patkhonsiam 23 months ago.
amperror.png (394.9 KB) - added by ehtis 23 months ago.

Download all attachments as: .zip

Change History (17)

#1 @SergeyBiryukov
23 months ago

  • Component changed from General to Toolbar
  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to 5.3.2
  • Version set to 5.3.1

Hi there, welcome to WordPress Trac! Thanks for the report.

Is there an error message referring to the script? What does it say?

Introduced in [46872] for #47069.

#2 @azaozz
23 months ago

@patkhonsiam could you please provide some more info:

  • The file /wp-includes/js/hoverintent-js.min.js is new in WP 5.3.1, there's no old version of it. Perhaps you mean /wp-includes/js/hoverintent.min.js (no -js before .min) which is the jQuery version of hoverIntent.
  • Where exactly are you seeing the error? Assuming it's on the front-end when you're logged in and using AMP. Do you see the same error in other places or cases?
  • Could you paste the exact error message from the browser console here please (you can replace sensitive information with dots).

#3 @patkhonsiam
23 months ago


I have tried to install version 5.3.1 and installed the AMP plug-in. After that, it was activated and used in standard mod. And the plug-in display the following errror message:

Please see image

Thank you

#4 @audrasjb
23 months ago

Hi @patkhonsiam

Are you using https://wordpress.org/plugins/amp/?
I can't reproduce the issue on my side.

Last edited 23 months ago by audrasjb (previous) (diff)

#5 @Murrejb
23 months ago


I have the exact same issue.

I'm using https://wordpress.org/plugins/amp/

I use the Astra Theme 2.1.4 By Brainstorm Force.

Thank you.

This ticket was mentioned in Slack in #core by audrasjb. View the logs.

23 months ago

#7 @audrasjb
23 months ago

  • Keywords has-screenshots needs-patch added; reporter-feedback removed
  • Owner set to audrasjb
  • Status changed from new to reviewing

I'm able to reproduce the issue with AMP plugin Standard option enabled.

23 months ago


#8 @ehtis
23 months ago

I'm able to reproduce this on a local install.

Installed AMP, switched to Standard mode, then visited Validated URLs.

Switched to Transitional mode and it was still showing.

Checked the attached screenshot:

Version 0, edited 23 months ago by ehtis (next)

#9 @karl94
23 months ago

This looks like a bug of the plugin. They are already working to fix it:

#10 @audrasjb
23 months ago

  • Keywords needs-patch removed
  • Milestone 5.3.2 deleted
  • Resolution set to reported-upstream
  • Status changed from reviewing to closed

Closed as reported upstream.
Thank you all for reporting this ticket :-)

#11 @beaubhavikwebslaw
13 months ago

//Beaubhavik Code = START
// Solution to confliction of jquery with seo plugin - Backend Side - 
function webslaw_hoverintent_reload() {
    wp_register_script('hoverIntent', ( 'https://cdnjs.cloudflare.com/ajax/libs/jquery.hoverintent/1.10.1/jquery.hoverIntent.min.js'), array('jquery'), 'r6.1');
add_action('admin_init', 'webslaw_hoverintent_reload');
//Beaubhavik Code = END
Last edited 13 months ago by beaubhavikwebslaw (previous) (diff)

#12 @boonebgorges
10 months ago

  • Resolution changed from reported-upstream to fixed

In 49830:

Query: Respect post-type specific capabilities when querying for multiple post types.

After this change, the relevant read_private_posts capability is checked for
each queried post type. This ensures that private posts appear in search and
archive queries for users who have the ability to view those posts.

Props leogermani.

Fixes #13509, #48968, #48556.

#13 @aaroncampbell
10 months ago

  • Resolution changed from fixed to reported-upstream

Setting back to reported-upstream - [49830] meant to reference #46968

#14 @peterwilsoncc
10 months ago

In 49832:

Coding Standards: Minor fixes following [49830].

See #13509, #48968, #48556.

#15 @peterwilsoncc
10 months ago

In 49833:

Coding Standards: Minor fixes following [49830].

Fixes the fixes missed in [49832]. They are fixed now.

See #13509, #48968, #48556.

Note: See TracTickets for help on using tickets.