WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 21 months ago

#48979 closed defect (bug) (fixed)

Twenty Twenty: Post nav pages link outside of the container

Reported by: ataurr Owned by: ianbelanger
Milestone: 5.4 Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: has-patch has-screenshots
Focuses: ui, css Cc:

Description

Hi
Template: Paginated pages are outside of the container. And it looks broked.

When I use insert read more tags from editor to make pages it showing in outside container

I think it should be the same align with content and page meta.

http://xpeedstudio.net/paging.png

example How it will look like after changes

Attachments (12)

paging.png (333.2 KB) - added by ataurr 2 years ago.
pages alignment
paging2.png (299.2 KB) - added by ataurr 2 years ago.
Capture d’écran 2019-12-16 à 23.54.01.png (45.1 KB) - added by audrasjb 2 years ago.
48979.diff: LTR languages
Capture d’écran 2019-12-16 à 23.55.58.png (51.6 KB) - added by audrasjb 2 years ago.
48979.diff: RTL languages
48979.diff (1.1 KB) - added by audrasjb 2 years ago.
48979.diff: Twenty Twenty: add margins to paginated links
Responsive.png (61.3 KB) - added by mukesh27 2 years ago.
Responsive design issue
48979.2.diff (524 bytes) - added by mukesh27 2 years ago.
Patch that fixed desktop and responsive issue.
48979-1000px.png (58.1 KB) - added by audrasjb 23 months ago.
48979.3.diff - responsive - 1000 px viewport width
48979-750px.png (54.2 KB) - added by audrasjb 23 months ago.
48979.3.diff - responsive - 750 px viewport width
48979-500px.png (50.8 KB) - added by audrasjb 23 months ago.
48979.3.diff - responsive - 500 px viewport width
48979-300px.png (38.8 KB) - added by audrasjb 23 months ago.
48979.3.diff - responsive - 300 px viewport width
48979.3.diff (3.4 KB) - added by audrasjb 23 months ago.
Bundled Themes: Twenty Twenty: Use consistent and responsive margins for pagination links.

Download all attachments as: .zip

Change History (30)

@ataurr
2 years ago

pages alignment

@ataurr
2 years ago

#1 @SergeyBiryukov
2 years ago

  • Summary changed from Post nav pages link outside of the container to Twenty Twenty: Post nav pages link outside of the container

#2 @abhishek403
2 years ago

hello @ataurr,

i think you need to add a class in main div and add css like this.

thank you.

.classname{
     postion:relative;
}
Version 0, edited 2 years ago by abhishek403 (next)

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


2 years ago

#4 @audrasjb
2 years ago

  • Focuses accessibility removed
  • Owner set to audrasjb
  • Status changed from new to accepted
  • Type changed from enhancement to defect (bug)
  • Version changed from 5.3.1 to 5.3

Hi @ataurr thanks for the ticket and welcome to WordPress Trac!

I can reproduce the issue on my side, but I don't think it's a regression from 5.3.1.
We'll probably address this in the next major, but leaving it in the milestone for now.

Cheers,
Jb

@audrasjb
2 years ago

48979.diff: LTR languages

@audrasjb
2 years ago

48979.diff: RTL languages

@audrasjb
2 years ago

48979.diff: Twenty Twenty: add margins to paginated links

#5 @audrasjb
2 years ago

  • Keywords has-patch has-screenshots added; needs-patch removed
  • Milestone changed from Awaiting Review to 5.3.2

In 48979.diff:
Twenty Twenty: add margins to paginated links

@mukesh27
2 years ago

Responsive design issue

@mukesh27
2 years ago

Patch that fixed desktop and responsive issue.

#6 @mukesh27
2 years ago

@audrasjb @ataurr I have updated the patch that fixed the desktop and responsive design issue.

#7 @audrasjb
2 years ago

  • Keywords needs-refresh added

@mukesh27 Thanks!
The patch should be generated against trunk/wordpress-dev. Adding needs-refresh keyword.
Also:

  • You also need to generate a patch for RTL stylesheet
  • It would be nice to remove paddings for elements inside the <nav> element (see 48979.diff)

#8 @audrasjb
2 years ago

  • Milestone changed from 5.3.2 to 5.3.3

Moving to milestone 5.3.3.

#9 @audrasjb
23 months ago

@mukesh27 I guess you didn't uploaded the good diff file because yours don't refresh anything from the previous patches, and there is no new CSS rules in Twenty Twenty’s media queries.

Below is an updated patch for this ticket. It addresses responsive support. I'll post various responsive situations screenshots as well.

@audrasjb
23 months ago

48979.3.diff - responsive - 1000 px viewport width

@audrasjb
23 months ago

48979.3.diff - responsive - 750 px viewport width

@audrasjb
23 months ago

48979.3.diff - responsive - 500 px viewport width

@audrasjb
23 months ago

48979.3.diff - responsive - 300 px viewport width

@audrasjb
23 months ago

Bundled Themes: Twenty Twenty: Use consistent and responsive margins for pagination links.

#10 @audrasjb
23 months ago

  • Keywords needs-refresh removed

#11 @audrasjb
22 months ago

  • Milestone changed from 5.3.3 to 5.4

Moving all unfixed tickets from 5.3.3 to milestone 5.4, as there is no plan for a 5.3.3 maintenance release for now.

#12 @audrasjb
22 months ago

Hi @ianbelanger, this one looks to be fixed on my side. Are you available to provide a quick review and commit it if it's ok?
Many thanks!

#13 @audrasjb
22 months ago

  • Keywords commit added

Patch is good to go, marking this for commit. cc @ianbelanger

#14 @ianbelanger
22 months ago

  • Owner changed from audrasjb to ianbelanger

Reviewing for commit.

#15 @ianbelanger
22 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 47244:

Bundled Themes: Twenty Twenty post navigation links outside of the container.

Fixes a bug where the in-page pagination does not align within the inner container.

Props ataurr, audrasjb, mukesh27.
Fixes #48979.

#16 @ianbelanger
22 months ago

  • Keywords fixed-major added; commit removed
  • Milestone changed from 5.4 to 5.3.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backport.

#17 @SergeyBiryukov
21 months ago

#49297 was marked as a duplicate.

#18 @audrasjb
21 months ago

  • Keywords fixed-major removed
  • Milestone changed from 5.3.3 to 5.4
  • Resolution set to fixed
  • Status changed from reopened to closed

Moving 5.3.3 Bundled Themes tickets back to milestone 5.4 as RC1 is approaching.

Note: See TracTickets for help on using tickets.