WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#48986 closed enhancement (duplicate)

Introduce a Site Health dashboard widget

Reported by: Clorith Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Site Health Keywords:
Focuses: Cc:
PR Number:

Description

The [Health Check plugin](https://github.com/wordpress/health-check] has been testing out the introduction of a dashbaord widget for some time now, to give the user a quick glance to see if they need to address anything upon logging in (of course dismissible like any other dashboard widget).

The widget relies on the last collected result of a health check, this means it also adds a WP_Cron event that runs the checks once a week (or whenever the Site Health check page is triggered).

Migrating this over would help gently nudge users towards fixing any critical issues on their site, be this core-provided checks, or plugins/themes not working as intended that have implemented checks to help users stay on top.

Change History (2)

#1 @SergeyBiryukov
2 months ago

Related/duplicate: #47606

#2 @Clorith
2 months ago

  • Milestone 5.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

It's apparently way too early in the morning, my searches did not reveal the original ticket of this at #47606

Note: See TracTickets for help on using tickets.