WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 2 months ago

#48995 closed defect (bug) (worksforme)

Failed to load plugin: wpeditimage from url .../wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js

Reported by: listalegal Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3.1
Component: TinyMCE Keywords: reporter-feedback
Focuses: ui Cc:

Description

Whenever I add a new Page or Post, or even if I edit an existing one I get this error message:
Failed to load plugin: wpeditimage from url .../wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js

I have newly installed version of WordPress 5.3.1 and I was using the default theme.
I switched to other themes but the error message persisted.

I'm attaching a screenshot of the error for my website https://www.attorneyfee.com
I'm also attaching a screenshot of the plugins I'm using. However this error persists even If I disable all plugins.

Thanks.

Attachments (1)

Screen Shot 2019-12-16 at 12.13.35 AM.png (392.6 KB) - added by listalegal 8 months ago.

Download all attachments as: .zip

Change History (5)

#2 @SergeyBiryukov
8 months ago

  • Component changed from General to TinyMCE
  • Keywords reporter-feedback added

Hi there, welcome to WordPress Trac! Thanks for the report.

Looks like the file is indeed missing on your install:

  • https://www.attorneyfee.com/wp-includes/js/tinymce/plugins/wpeditimage/plugin.js does exist.
  • https://www.attorneyfee.com/wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js returns a 404 error.

As seen in https://build.trac.wordpress.org/browser/tags/5.3.1/wp-includes/js/tinymce/plugins/wpeditimage, they should both exist in that directory.

Could you reupload the file and check again?

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


8 months ago

#4 @azaozz
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

As Sergey points out above this is caused by a missing file or (in rare cases) the file may be blocked on the server by some security restriction or improper file permissions.

Closing as worksforme as this doesn't seem like a bug in core. If it is, feel free to reopen with more info on how to reproduce.

Note: See TracTickets for help on using tickets.