WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 4 weeks ago

#49048 closed enhancement (fixed)

Add unit tests for v5.3.1 block serialization functions

Reported by: aduth Owned by: whyisjake
Milestone: 5.3.3 Priority: normal
Severity: normal Version: 5.3.1
Component: Editor Keywords: fixed-major commit
Focuses: Cc:

Description

r46896 was intended to have included unit tests for the block serialization functions added as part of the changeset.

The attached patch includes those tests.

Attachments (1)

49048.diff (1.9 KB) - added by aduth 2 months ago.

Download all attachments as: .zip

Change History (6)

@aduth
2 months ago

#1 @whyisjake
2 months ago

  • Owner set to whyisjake
  • Status changed from new to assigned

#2 @whyisjake
2 months ago

  • Keywords commit added

#3 @whyisjake
2 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 46997:

Editor: Add unit tests for v5.3.1 block serialization functions

r46896 was intended to have included unit tests for the block serialization functions added as part of the changeset.

Props: @aduth.
Fixes: #49048

#4 @johnbillion
2 months ago

  • Keywords fixed-major added; has-patch removed
  • Milestone changed from Awaiting Review to 5.3.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

Let's port this to the 5.3 branch.

#5 @SergeyBiryukov
4 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 47131:

Editor: Add unit tests for v5.3.1 block serialization functions.

[46896] was intended to have included unit tests for the block serialization functions added as part of the changeset.

Props aduth.
Merges [46997] to the 5.3 branch.
Fixes #49048.

Note: See TracTickets for help on using tickets.