Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#49062 closed defect (bug) (invalid)

Twenty Twenty Style sheet Showing Error

Reported by: prashantvatsh's profile prashantvatsh Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3.2
Component: Bundled Theme Keywords: dev-feedback
Focuses: css, administration Cc:

Description

I have the latest WordPress installation with the twenty-twenty theme and no active plugin on my localhost. As soon as I have opened the theme editor I saw this error. Please see: https://prnt.sc/qe0vmk

Change History (5)

#1 @SergeyBiryukov
3 years ago

  • Component changed from Administration to Bundled Theme

#2 follow-up: @SergeyBiryukov
3 years ago

Hi there, thanks for the ticket!

I was able to reproduce the issue. It's not quite clear what exactly the error is, since there's no error message, and in my testing when trying to find out which CSS rules cause the error I got different results every time.

In general, the theme editor's CSS linting appears to be not very reliable and should probably be disabled by default. There is some consensus on doing that in #44471.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#3 in reply to: ↑ 2 ; follow-up: @SergeyBiryukov
3 years ago

Replying to SergeyBiryukov:

It's not quite clear what exactly the error is, since there's no error message, and in my testing when trying to find out which CSS rules cause the error I got different results every time.

As an example, this CSS file displays the same "There is 1 error" message without showing the exact error:

/*
Theme Name: Twenty Twenty
*/

body.template-full-width .entry-content > .alignright {
	margin-right: calc(( 100vw - 120rem ) / 2);
}

Removing the spaces around the inner brackets (100vw - 120rem) appears to somehow "resolve" it.

#4 in reply to: ↑ 3 @prashantvatsh
3 years ago

Replying to SergeyBiryukov:

Replying to SergeyBiryukov:

It's not quite clear what exactly the error is, since there's no error message, and in my testing when trying to find out which CSS rules cause the error I got different results every time.

As an example, this CSS file displays the same "There is 1 error" message without showing the exact error:

/*
Theme Name: Twenty Twenty
*/

body.template-full-width .entry-content > .alignright {
	margin-right: calc(( 100vw - 120rem ) / 2);
}

Removing the spaces around the inner brackets (100vw - 120rem) appears to somehow "resolve" it.

Just now I tried this in the editor but for me, it did not resolve it and still, it is showing there is 1 error.

#5 @ianbelanger
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Since this issue does not seem to be specifically with Twenty Twenty, but with the theme editor, I am closing this as invalid.

Note: See TracTickets for help on using tickets.