WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#4908 closed enhancement (duplicate)

add_menu_page() should be able to not made it's own sub-menu

Reported by: Viper007Bond Owned by:
Milestone: Priority: low
Severity: trivial Version: 2.3
Component: Administration Keywords:
Focuses: Cc:

Description

Currently, when you use add_menu_page(), it automatically makes a top-level menu (this is good), but then goes on to make a sub-menu of the same name under itself (this can be annoying).

I'd like it a lot better if it didn't and we had to do add_submenu_page() to get a sub-menu. Then we could do menu pages much like the rest of WordPress (ex: Options -> General rather than Options -> Options).

For backwards compatibility though, we'd probably have to make it an additional parameter tagged onto the end of add_menu_page().

Change History (4)

comment:1 @Viper007Bond8 years ago

  • Cc wptrac@… added

comment:2 @ffemtcj7 years ago

  • Milestone changed from 2.5 to 2.6

comment:3 @jacobsantos7 years ago

Has this changed in 2.7?

comment:4 @janbrasna7 years ago

  • Keywords needs-patch removed
  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #5100 (which contains more info).

Note: See TracTickets for help on using tickets.