WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 2 months ago

#49080 closed defect (bug) (duplicate)

Cropping images in the Media Library doesn't affect post thumbnails

Reported by: pikamander2 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Create a 900x2000 image.
  2. Use the Media Library to crop it down to 900x400 (and save it).
  3. Add the featured image to a post.
  4. Visit the post.
  5. Note that the original image appears, not the cropped version.

You can work around this by installing the third-party Regenerate Thumbnails plugin and clicking the "Regenerate image sizes" link on the post page.

But why does this happen in the first place? It doesn't seem like the correct behavior. When an image is cropped in the Media Library, you would expect that to be roughly equivalent to uploading a new image that had been cropped beforehand.

Change History (3)

#1 @sabernhardt
2 months ago

  • Component changed from Upload to Media

This ticket was mentioned in Slack in #core-media by sabernhardt. View the logs.


2 months ago

#3 @sabernhardt
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @pikamander2 and thanks for the report!

#42922 seems to be the same issue. If you would like, please continue the discussion there.

Note: See TracTickets for help on using tickets.