Make WordPress Core

Opened 4 years ago

Closed 17 months ago

Last modified 15 months ago

#49099 closed enhancement (fixed)

Twenty Twenty: Add social icon for Mastodon

Reported by: rryyaanndd's profile rryyaanndd Owned by: audrasjb's profile audrasjb
Milestone: 6.2 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: Cc:

Description (last modified by sabernhardt)

Please add a social icon for Mastodon in the Twenty Twenty Theme.

Attachments (1)

Capture d’écran 2020-01-11 à 17.47.28.png (51.1 KB) - added by audrasjb 4 years ago.
Mastodon icon on Twenty twenty

Download all attachments as: .zip

Change History (9)

#1 @audrasjb
4 years ago

  • Keywords reporter-feedback close added

Hi and thank you for opening this ticket,
Mastodon icon is already available, but it's only triggered if the provided URL contains mastodon.com URL.

@audrasjb
4 years ago

Mastodon icon on Twenty twenty

#2 @ianbelanger
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as a worksforme

#3 @rryyaanndd
4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The problem is mastodon.com isn't a real domain name for mastodon instances. So nobody will use that icon since there will never be a link to that domain.
There are many different domains for mastodon instances (thousands):

https://joinmastodon.org/#getting-started
https://instances.social/list/advanced

#4 @ianbelanger
4 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

Hi @rryyaanndd,

Because of the way the social icon navigation works, using the url to trigger the correct icon and since there are thousands of domain instances for mastodon, I am not sure that we can add mastodon as an option at this point. If you can provide a solution that works, please submit a patch here or create a plugin. At this point though I am closing this ticket as a wontfix.

#5 @sabernhardt
18 months ago

  • Description modified (diff)
  • Keywords reporter-feedback close removed
  • Milestone set to 6.2
  • Resolution wontfix deleted
  • Status changed from closed to reopened

We should map at least the original Mastodon domain, mastodon.social, so the theme does not check mastodon.com. Discussion about adding a small selection of other possibilities is on #57293.

#6 @audrasjb
17 months ago

  • Owner set to audrasjb
  • Resolution set to fixed
  • Status changed from reopened to closed

In 55061:

Bundled Themes: Add Mastodon domains for menu item icons.

This changeset adds the top 10 Mastodon domains by popularity to Twenty Twenty and Twenty Twenty-One Social icon feature.

Note: other Mastodon domains can be added to the array of domain mapping using twentytwenty_social_icons_map and twenty_twenty_one_social_icons_map filters.

Props triumvirate, sabernhardt, audrasjb, peterwilsoncc, rryyaanndd, ianbelanger.
Fixes #57293, #49099.

#7 @milana_cap
15 months ago

  • Keywords needs-user-docs added

#8 @milana_cap
15 months ago

  • Keywords needs-user-docs removed
Note: See TracTickets for help on using tickets.