WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#49128 closed defect (bug) (invalid)

Some lines without translation (site health) (core)

Reported by: SergeyKovalets Owned by:
Milestone: Priority: normal
Severity: trivial Version: 5.3.2
Component: Site Health Keywords:
Focuses: Cc:

Description

In any locale, some translated lines are displayed in their original form.

Attachments (3)

2020-01-03 220304.png (26.7 KB) - added by SergeyKovalets 5 months ago.
49128.PNG (28.3 KB) - added by SergeyBiryukov 5 months ago.
screenshot.png (68.3 KB) - added by fierevere 5 months ago.
ru_RU, site health

Download all attachments as: .zip

Change History (10)

#1 @fierevere
5 months ago

As i remember it's been issue with beta versions when Site Health was just integrated into core, i have never seen this problem reproducible again with ru_RU at least.

@SergeyBiryukov
5 months ago

@fierevere
5 months ago

ru_RU, site health

#2 follow-up: @SergeyBiryukov
5 months ago

Hi there, welcome to WordPress Trac! Thanks for the report.

I could not reproduce the issue on a clean install with the Ukrainian locale, all the strings are translated: 49128.PNG.

Do you have any pending translation updates in Dashboard → Updates?

#3 follow-up: @diddledan
5 months ago

I've had a quick browse of the sourcecode for site-health and I cannot see any strings that do not have correct internationalisation wrappers (they're all correctly internationalised), so if there are untranslated strings then likely the localisation files are incomplete (as Sergey suggests there might be a downloadable update).

#4 in reply to: ↑ 2 @SergeyKovalets
5 months ago

Replying to SergeyBiryukov:

Hi there, welcome to WordPress Trac! Thanks for the report.

I could not reproduce the issue on a clean install with the Ukrainian locale, all the strings are translated: 49128.PNG.

Do you have any pending translation updates in Dashboard → Updates?

No updates.
Perhaps the problem is in my hosting.
I have 12 sites on one hosting, my clients use this hosting and they have the same problems.

#5 in reply to: ↑ 3 @SergeyKovalets
5 months ago

Replying to diddledan:

I've had a quick browse of the sourcecode for site-health and I cannot see any strings that do not have correct internationalisation wrappers (they're all correctly internationalised), so if there are untranslated strings then likely the localisation files are incomplete (as Sergey suggests there might be a downloadable update).

Excellent. Thank you for your attention.
Apparently this is the problem of my hosting.
I will try to find out what affects this.

#6 @SergeyKovalets
5 months ago

  • Severity changed from normal to trivial

Is defined. The problem is in the Yoast SEO plugin.
When it is deactivated, the problem disappears.

#7 @SergeyBiryukov
5 months ago

  • Keywords needs-patch reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.