WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#49134 closed defect (bug) (fixed)

Missing translation string in media-views.js

Reported by: audrasjb Owned by: SergeyBiryukov
Milestone: 5.3.3 Priority: normal
Severity: normal Version: 5.3
Component: Media Keywords: has-patch fixed-major
Focuses: Cc:

Description (last modified by audrasjb)

Since changeset [46375], there is a missing translation string in media-views.js.
In trunk, this file is located in src/js/media/views/selection.js

The following string doesn't appear in translate.w.org:
sprintf( _n( '%s item selected', '%s items selected', collection.length ), collection.length )

Thanks @ysatis who initially raised this regression on the French support forum: https://wpfr.net/support/sujet/une-expression-sest-retransformee-en-anglais/

Attachments (1)

Capture d’écran 2020-01-05 à 11.38.59.png (563.4 KB) - added by audrasjb 6 months ago.
To reproduce the issue, use for example a gallery block and select one or more items in the media library.

Download all attachments as: .zip

Change History (7)

@audrasjb
6 months ago

To reproduce the issue, use for example a gallery block and select one or more items in the media library.

#1 @ocean90
6 months ago

In 47040:

Media: After [46375], enable JavaScript translations for the media-views script.

See #49134.

#2 @ocean90
6 months ago

  • Component changed from I18N to Media
  • Keywords has-patch fixed-major added; needs-patch removed
  • Milestone changed from Awaiting Review to 5.3.3

The string is available for translation but the translation wasn't loaded because the text domain wasn't set for the script.

#3 @audrasjb
6 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for committing this patch.
Closing as fixed.

#4 @audrasjb
6 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for potential backport in branch 5.3.

#5 @audrasjb
6 months ago

  • Description modified (diff)

#6 @SergeyBiryukov
6 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 47126:

Media: After [46375], enable JavaScript translations for the media-views script.

Props ocean90, audrasjb.
Merges [47040] to the 5.3 branch.
Fixes #49134.

Note: See TracTickets for help on using tickets.