WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 19 months ago

Last modified 14 months ago

#49165 closed defect (bug) (invalid)

Alt Text Not Saving Outside of Library

Reported by: upgradedkellie Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: has-screenshots
Focuses: ui, accessibility Cc:

Description

Hi There,

When we try to update the Alt Text to an image, it's only saving the Alt Text within the post and not updating the Alt Text associated with the image in the Library. Is this expected?

Best,

Kellie

Change History (8)

#1 follow-up: @sabernhardt
21 months ago

  • Keywords reporter-feedback added

Welcome @upgradedkellie and thanks for the ticket!

To make sure I understand the issue correctly, are you using the Block Editor's sidebar to edit the Alt Text when it does not update in the Media Library? Or do you see this in a different situation?

(The Gutenberg issue was reported here: https://github.com/WordPress/gutenberg/issues/8941 )

#2 in reply to: ↑ 1 @upgradedkellie
21 months ago

Replying to sabernhardt:

Welcome @upgradedkellie and thanks for the ticket!

To make sure I understand the issue correctly, are you using the Block Editor's sidebar to edit the Alt Text when it does not update in the Media Library? Or do you see this in a different situation?

(The Gutenberg issue was reported here: https://github.com/WordPress/gutenberg/issues/8941 )

Hi Stephen,

Thanks for the help. I believe so, but let me give you my "Steps to Reproduce" just in case I have the terminology wrong. I should have included that in the first place; I'm so sorry.

  1. Access any Post with an image.
  2. Click on image then click "Pencil" edit icon.
  3. This bring up Image Details. Add new Alt Text where blank: https://monosnap.com/file/esggfr7ONy5KOB1phnAFPhERuYXuIt
  4. Click Update.
  5. Click Media.
  6. Locate photo from Post
  7. View blank Alt Text https://monosnap.com/file/zq1j8mQnHvPNKcDYM8lzjK9wYhZb0e

Best,

Kellie

#3 @SergeyBiryukov
21 months ago

  • Component changed from General to Media

#4 @sabernhardt
21 months ago

  • Focuses ui accessibility added
  • Keywords 2nd-opinion has-screenshots added; reporter-feedback removed

Thanks for the steps! So this is a similar but separate issue from the one I thought.

Using the Visual Editor (Classic), I see your result when editing alt text within the post. Likewise, if you edit the alt text in the Media Library after attaching an image to a post, it does not update the alt text for that image within the post content.

Since there are some situations where you might want different alt text for the same image in another post or in another context, the discrepancy could be on purpose (see Sergey's comment on ticket:47808#comment:2). One example of a different context for the same image is a custom header image (see ticket:46124).

It's worth leaving those text values separate. However, I myself thought that editing the post image's alt text within the Image Details dialog would update it within the library. Maybe we could enhance the interface by adding a checkbox or some other way to indicate the desire to update these values in the Media Library as well.

I'll add the 2nd-opinion keyword to encourage further discussion.

Last edited 21 months ago by sabernhardt (previous) (diff)

#5 @SergeyBiryukov
21 months ago

Related/duplicate: #47808

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


19 months ago

#7 @afercia
19 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This ticket was discussed during today's accessibility bug-scrub. This works as expected but it's clear that the user interface could be more... clear. There's a ticket for that! See #47456. Please do feel free to join the conversation and contribute there!

#8 @vigilant_spb
14 months ago

Maybe we could enhance the interface by adding a checkbox or some other way to indicate the > desire to update these values in the Media Library as well.

PLEASE do this!

  1. When you drag and drop and image to the Gutenber editor it's super easy, you can add your alt BUT it won't appear in medialibrary for reuse AND FOR SEARCH!! How to find some old photo?

2 When you D&D several images (gallery) you can't use alt - no such a field. Changing alt in medialibrary has no effect on published post...

Old versions worked perfectly with title/alt, I had no problems, but this new behavior... Something wrong with it.

  • also my workflow was like "write post adding photos, 50 pics for example, and after post is ready check all the titles/alts in ML", I mean changing it after in a row is more easy than change it for every single uploaded photo in the moment I upload
Note: See TracTickets for help on using tickets.