WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4921 closed defect (bug) (fixed)

Errors durung 2.2.x to 2.3 upgrade

Reported by: Nazgul Owned by: Nazgul
Milestone: 2.3 Priority: high
Severity: major Version: 2.3
Component: General Keywords: has-patch
Focuses: Cc:

Description

The following errors are shown during a 2.2.x to 2.3 upgrade:

WordPress database error: [Field 'option_description' doesn't have a default value]
INSERT INTO wp_options (option_name, option_value, autoload) VALUES ('new_users_can_blog', '0', 'yes')

WordPress database error: [Field 'option_description' doesn't have a default value]
INSERT INTO wp_options (option_name, option_value, autoload) VALUES ('tag_base', '', 'yes')

This is caused by calling populate_options before upgrade_230_options_table during the upgrade.

Attachments (1)

4921.diff (631 bytes) - added by Nazgul 7 years ago.

Download all attachments as: .zip

Change History (3)

Nazgul7 years ago

comment:1 Nazgul7 years ago

  • Keywords has-patch added
  • Owner changed from anonymous to Nazgul
  • Status changed from new to assigned

comment:2 markjaquith7 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6053]) Upgrade the options table before calling populate_options() to avoid errors. Props Nazgul. fixes #4921

Note: See TracTickets for help on using tickets.