WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#49253 closed defect (bug) (invalid)

Readme.txt "Tested up to:" is now ignored

Reported by: reidbusi Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: administration Cc:

Description

If a plugin is not in the wordpress.org repository it appears that the Readme.txt "Tested up to:" is now ignored. When updating a plugin tested up to 5.3.2 on WP 5.3.2, on the update page WP reports:

"Compatibility with WordPress 5.3.2: Unknown"

So. Is there a way to fix this, or are all independent plugins now considered incompatible with wordpress?

Do I need to create a "lite" version of the same slug in the wordpress.org repo? Is that why people do that underhanded gimpware thing here so much?


Change History (11)

#1 @carike
2 months ago

We are working on adding new headers related to privacy (disclosures / compliance), both for meta and for core.
I'll ask the developer who is helping us with the headers for core to take a look at this ticket.

This ticket was mentioned in Slack in #core-privacy by carike. View the logs.


2 months ago

This ticket was mentioned in Slack in #core-site-health by carike. View the logs.


2 months ago

#4 @carike
2 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #meta4621.

Timothy pointed me towards another ticket that seems to be a duplicate of this one, so going to mark this one as closed for now :)

Last edited 2 months ago by SergeyBiryukov (previous) (diff)

#5 @SergeyBiryukov
2 months ago

  • Component changed from General to Plugins
  • Focuses administration added

#6 @reidbusi
2 months ago

4261 is not a duplicate of this, that is a separate discussion. I am talking about production WP 5.3.2. Right now. it is broken. What used to work does not work anymore. Discussion of a new set of related features is irrelevant.

This is a bug report. Not a discussion of new features. PHP versions have nothing to do with it.

The current documentation for WordPress instructs authors to put "Tested up to:" in the readme text header - then ignores it.

So either change the documentation or fix the code. If you need help with it, let me know and I can try to make some time to work on the documentation or the code so that we have situation where they match.

But preferably I'd rather not see the documentation edited to make the broken code "wai".

#7 @carike
2 months ago

This is a bug report. Not a discussion of new features. PHP versions have nothing to do with it.

The meta ticket that I linked to is called

"Add support for 'Tested up to' header in the main plugin file".

PHP versions are mentioned in contrast, but they are not what that ticket is about.

I am talking about production WP 5.3.2. Right now.

The privacy headers will be included in the repo, but they will also be needed in core.
While we are updating headers for core, we might as well fix this one while we are at it (if it is not fixed already by the linked meta ticket).

So either change the documentation or fix the code. If you need help with it, let me know and I can try to make some time to work on the documentation or the code so that we have situation where they match.

The example readme.txt is currently being updated to reflect new headers and is already scheduled to replace the current readme.txt in the Developer Handbook. It is specifically included on the #docs team agenda, with weekly progress reports.
Again, while we are updating that, we might as well fix this at the same time.

#8 @reidbusi
2 months ago

OK fine. I will fix the current code myself. I have a hotel safety meeting in an hour and I have to visit a financial institution client on site and perform pre-production QA on an entirely new stack of business software to replace the current one they use, then implement it on 25 workstations, and I have to have a draft genealogy website ready for a client on Friday, and I still do not have enough money to eat. Rent is paid thankfully.

So I will make some time tonight, I'm not sleeping well anyway, and I will just fix this myself and submit a patch.

I would be more interested in contributing, if WP core was not going the way it is going (I can see the agile scrums now - how can we fuck up the product today?).

#9 @SergeyBiryukov
2 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Thanks for the ticket! Reopening for now for a closer review.

#10 @reidbusi
2 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Nevermind. The problem I was observing is the fault of WooCommerce API Manager. I have fixed it, but I will not send the fix to the author, since the extension is distributed as gimpware. Should that change, I will contribute to it.

This was not a core issue. I'll go eat crow now. Carry on.

#11 @SergeyBiryukov
2 months ago

  • Milestone Awaiting Review deleted

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.