WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#49281 closed defect (bug) (invalid)

posts without title cannot go to the recycle bin

Reported by: yjeanrenaud Owned by:
Milestone: Priority: normal
Severity: trivial Version: 5.3.2
Component: Posts, Post Types Keywords:
Focuses: ui, administration Cc:

Description

I created a test post draft and saved it with the classic editor. I wanted to move it to the bin but this failed until I gave it a title. same applies for block editor.

Attachments (2)

bin-fail.PNG (6.4 KB) - added by yjeanrenaud 4 months ago.
bin-fail-block.PNG (102.2 KB) - added by yjeanrenaud 4 months ago.

Download all attachments as: .zip

Change History (6)

@yjeanrenaud
4 months ago

#1 @audrasjb
4 months ago

Hello and welcome to WordPress Trac,

It's because the post doesn't exists in the database until it has a title (which is saving it as a revision).

Instead of trying to move it to the Trash, try to click on one of the WP-Admin menu, you'll be redirected directly to this menu without any prompt asking you to save the post… because the post doesn't exists yet.

Last edited 4 months ago by audrasjb (previous) (diff)

#2 @yjeanrenaud
4 months ago

but I can save it. it exists.

#3 @xkon
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey @yjeanrenaud and welcome to Trac! Thanks for reporting this :-).

I've run some tests on my live sites that are on 5.3.2 as well but I couldn't reproduce the issue.

My test-cases, everything was tested on both Editor / Classic Editor & Posts/Pages:

  • Opening the editor, if nothing is changed there's no Delete button at all.
  • Saving a Draft (no title/no content) the delete button appears and works as expected.
  • By entering some content only (no title) the delete button appears after either Save Draft or Publish, and works again as expected.

I don't think that I've left a case out and I've tried multiple times also from various browsers and different sites without any errors.

I'm thinking that there might be something specific to your website only that produces this behavior and it would be easier to find some help at the Support Forums https://wordpress.org/support/forums/ .

#4 @SergeyBiryukov
4 months ago

  • Component changed from General to Posts, Post Types
  • Focuses administration added
Note: See TracTickets for help on using tickets.