WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#49297 closed defect (bug) (duplicate)

Twenty Twenty theme "Clearing Floats" issue

Reported by: fahimmurshed Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: close
Focuses: css Cc:

Description

Please check "Clearing Floats" by ThemeUnitTest xml file.

Go to /wp-content/themes/twentytwenty/style.css:2607

Change

margin-top:2em;

to

margin-top: 10em;

Screenshot:

Attachments (2)

1.PNG (103.9 KB) - added by fahimmurshed 3 months ago.
2.PNG (90.7 KB) - added by fahimmurshed 3 months ago.

Download all attachments as: .zip

Change History (13)

@fahimmurshed
3 months ago

@fahimmurshed
3 months ago

#1 @joyously
3 months ago

This was supposedly fixed back in September. See https://github.com/WordPress/twentytwenty/issues/204
Perhaps other changes have brought it back? Or the margins are not applied except in .entry-content?

#2 @SergeyBiryukov
2 months ago

  • Component changed from Themes to Bundled Theme
  • Keywords needs-unit-tests removed

#3 @ianbelanger
2 months ago

  • Focuses css added
  • Version changed from 5.3.2 to 5.3

#4 @ianbelanger
2 months ago

  • Keywords needs-patch added; needs-testing removed
  • Milestone changed from Awaiting Review to Future Release

I can confirm the issue does still exist. However, the solution that you suggest @fahimmurshed will only work if the image is a particular size, and if there is no floated image at the end, then the margin is to big. We definitely need to find a fix for this though.

#5 @fahimmurshed
2 months ago

Thanks so much, Ian.

I'll find more issues.

#6 @fahimmurshed
2 months ago

@ianbelanger,

Got a few ERROR on the Theme Sniffer. Can you please check with Theme Sniffer plugin?

#7 @fahimmurshed
6 weeks ago

I have checked and it's solved on WordPress 5.4 beta

Thanks a lot.

This ticket was mentioned in Slack in #core by murshed. View the logs.


6 weeks ago

#9 @ianbelanger
6 weeks ago

  • Keywords close added; needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

This appears to have been fixed by #48979.

#10 @SergeyBiryukov
6 weeks ago

  • Resolution changed from fixed to duplicate

Duplicate of #48979.

#11 @SergeyBiryukov
6 weeks ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.