WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#49338 closed defect (bug) (duplicate)

Hello Dolly Plugin can be installed twice

Reported by: rkradadiya Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

Hello,

I noticed an issue with Hello Dolly Plugin. I am able to install the plugin twice. Please see the video to understand the scenario.

Video URL - https://www.screenpresso.com/=6bHJc

Thanks,
Rajesh

Attachments (1)

2020-02-01_17h13_06.png (96.4 KB) - added by rkradadiya 4 months ago.

Download all attachments as: .zip

Change History (5)

#1 @knutsp
4 months ago

  • Focuses accessibility removed
  • Keywords needs-patch removed
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.3.2 deleted

Hello and welcome to Trac.

Thank you for the ticket.

You probably have two instances of the plugin's main .php file, moved the files or renamed the folder. There is no possible bug, as there is no code to prevent two equally named or working plugins to be installed, if they have a different file or folder name.

Suggest you delete both, then reinstall. If you need help, please try our support forums https://wordpress.org/support/forums/

#2 @rkradadiya
4 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

@knutsp

I have to say there are not created theme folder by me. this issue is with fresh WordPress.
Please setup fresh WordPress and then test.

#3 @knutsp
4 months ago

  • Component changed from Plugins to Upgrade/Install
  • Keywords 2nd-opinion added
  • Severity changed from normal to minor
  • Summary changed from Default Hello Dolly Plugin bug in WordPress Version 5.3.2 to Hello Dolly Plugin can be installed twice

Correct. The bundled Hello Dolly is just a hello.php file in plugins, while the repo one comes in a folder hello-dolly.

It will require some extra upgrade operations to "move" a bundled plugin (add new, delete old, check if active, maybe activate new), for each site in multisite.

#4 @ocean90
4 months ago

  • Component changed from Upgrade/Install to Plugins
  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

This is a duplicate of #37351 and #29540.

Note: See TracTickets for help on using tickets.