WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 7 months ago

#49353 closed defect (bug) (fixed)

button padding issue in edit plug on small device

Reported by: passoniate Owned by: afercia
Milestone: 5.4.2 Priority: normal
Severity: normal Version: 5.4
Component: Editor Keywords: has-screenshots has-patch fixed-major
Focuses: ui, css Cc:

Description

button padding issue in edit plug on small device

Attachments (5)

editor-button.png (20.7 KB) - added by passoniate 10 months ago.
49353.patch (524 bytes) - added by garethgillman 10 months ago.
removes bottom and top padding under 782px
49353.diff (507 bytes) - added by afercia 7 months ago.
49353 Look Up.png (73.7 KB) - added by afercia 7 months ago.
Look Up button with the patch applied in the responsive view
49353 Select.png (44.9 KB) - added by afercia 7 months ago.
Select files button with the patch applied in the responsive view

Download all attachments as: .zip

Change History (12)

#1 @passoniate
10 months ago

@afercia

@garethgillman
10 months ago

removes bottom and top padding under 782px

#2 @afercia
7 months ago

  • Keywords has-patch added

Looks like the submit button was already fixed in [47071] / #49197.

Version 0, edited 7 months ago by afercia (next)

#3 @afercia
7 months ago

  • Milestone changed from Awaiting Review to 5.4.2

@afercia
7 months ago

#4 @afercia
7 months ago

49353.diff removes the exceptions for the styling of the "Select plugin/theme to edit" and documentation "Look Up" buttons. These buttons should just use the default buttons style.

This ticket seems to me a nice candidate for a point release as it's a regression from 5.3.x, the patch is straightforward and self-contained.

@afercia
7 months ago

Look Up button with the patch applied in the responsive view

@afercia
7 months ago

Select files button with the patch applied in the responsive view

#5 @afercia
7 months ago

  • Owner set to afercia
  • Resolution set to fixed
  • Status changed from new to closed

In 47751:

File Editor: Remove CSS exceptions for the "Select plugin/theme to edit" and documentation "Look Up" buttons.

Buttons should use the default buttons styles, no exceptions.

Props passoniate, garethgillman.
See #49197.
Fixes #49353.

#6 @afercia
7 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for 5.4.2 consideration.

#7 @whyisjake
7 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 47824:

File Editor: Remove CSS exceptions for the "Select plugin/theme to edit" and documentation "Look Up" buttons.
Buttons should use the default buttons styles, no exceptions.

This commit bring the changes from [47751] to the 5.4 branch.

Props passoniate, garethgillman, @afercia.
See #49197.
Fixes #49353.

Note: See TracTickets for help on using tickets.