WordPress.org

Make WordPress Core

Opened 8 weeks ago

Closed 7 weeks ago

#49366 closed defect (bug) (duplicate)

Username with spaces causes login loop

Reported by: xaeronl Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords:
Focuses: Cc:

Description

When using PHP 7.4.2 with WordPress 5.3.2 and having an username with a space in it (e.g. 'test test') WordPress will be stuck in a loop. The login is successfull and redirects you to the desired page. After that, it will be redirected back to the wp-login.php page and requests a &reauth=1

Using PHP 7.3.14 this issue does not exists.

Change History (3)

#1 @SergeyBiryukov
8 weeks ago

Hi there, welcome WordPress Trac! Thanks for the report.

Just adding links to some related tickets here: #23638, #27740, #34372, #44690.

Last edited 8 weeks ago by SergeyBiryukov (previous) (diff)

#2 @johnbillion
8 weeks ago

Seeing this issue too on a site running PHP 7.4

#3 @ocean90
7 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.3.2 deleted

Apparently it's a bug introduced in PHP 7.4.2. Going to close this report as a duplicate of #49395 which provides more information about that PHP bug.

Note: See TracTickets for help on using tickets.