WordPress.org

Make WordPress Core

Opened 8 weeks ago

Closed 8 weeks ago

Last modified 7 weeks ago

#49420 closed defect (bug) (invalid)

Multi site shows always wrong upload limit

Reported by: aceone999 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upload Keywords:
Focuses: multisite Cc:

Description

I have multi site with php upload limit 2GB post size limit 2GB running with nginx web-server on my on server, upload limit in nginx set to: 2GB

The wordpress site displays 1mb upload limit. I can’t upload bigger files.
Only the html upload allows me to upload bigger files ,even when it still says “limit 1 MB”
I tried all possible things to fix this, wp-config.php, functions.php, php.ini, nothing worked. Deactivated all plugins using standard theme.
All other wordpress’s that are installed on this user account on this server show an upload limit of 2 GB as they should.

The only fix I found is to remove the multi site part from wp-config. As soon as I remove this part it shows the upload limit correctly as: “2 GB”.

This is what I removed from wp-config.php:
/* Multisite */
define( ‘WP_ALLOW_MULTISITE’, true );
define(‘MULTISITE’, true);
define(‘SUBDOMAIN_INSTALL’, true);
define(‘DOMAIN_CURRENT_SITE’, ‘example.com’);
$base = ‘/’;
define(‘PATH_CURRENT_SITE’, ‘/’);
define(‘SITE_ID_CURRENT_SITE’, 1);
define(‘BLOG_ID_CURRENT_SITE’, 1);
define(‘WP_ALLOW_REPAIR’, true);`

Steps to reproduce:

  • Install wordpress
  • Install multi site for sub domains after wordpress is all ready installed.

Change History (2)

#1 @desrosj
8 weeks ago

  • Component changed from Media to Upload
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version 5.3.2 deleted

Hi @aceone999,

Thanks for this ticket, and welcome to Trac! For future reference, this is a request better suited for the WordPress.org support forums. This Trac instance is for tickets related to developing WordPress Core.

I believe that the behavior you are describing is the intended behavior. By default, each individual site within a multisite install limits uploads to 1MB per file. If this is too low for you, you can adjust this by visiting My Sites > Network Admin > Settings in the WP Admin Toolbar at the top of the screen.

If you scroll down, there is a setting "Max upload file size" that defaults to 1MB. Changing this will change the maximum file upload size for the sites on the network.

If this does not work for you, or you are able to provide more steps to reproduce the issue, feel free to reopen this ticket with more details.

#2 @aceone999
7 weeks ago

Thank you. I posted it already in the forums, but answer for weeks.
https://wordpress.org/support/topic/cant-set-max-upload-size-limit/

Note: See TracTickets for help on using tickets.