WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 5 weeks ago

#49439 closed enhancement (duplicate)

Make front/blog/privacy page easier to find in posts list table

Reported by: scienceofspock Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.3.2
Component: Posts, Post Types Keywords:
Focuses: ui, administration Cc:

Description

I work on a number of sites that have been in existence for several years, and most of these sites have several HUNDRED pages. It has become very time consuming to find the "Front Page" or the "Blog Page" or any of the other "main" pages by flipping through 20 or 30 pages of pages or using the search. These pages are marked in the UI as "<Title_of_page> - Front Page" or "<Title_of_page> - Blog Page", but searching for "Front page" of "Blog page" does not single out these pages.

Can we get some option that either places these "main" pages at the top/front of the page list (As they are arguably the most important pages) or perhaps make the search robust enough to recognize specific key words like "Front" or "Blog" in a search and prioritize those "main" pages when they are searched? At the very least, can we get a checkbox to search page titles only instead of also searching the content? I find that the vast majority of the time, I am searching for pages based on title, not their content.

I realize there is an "Edit page" link in the admin bar, but I do not use the admin bar because it often times interferes in the design process.

Change History (5)

#1 @valentinbora
7 weeks ago

Hi @scienceofspock and thank you for submitting this ticket. I understand your frustration and would like to assure you that we're all interested in making WordPress better.

Would you mind changing the ticket title to something that would make it easier to find in our list? Something along the lines of "Make the Front Page and Posts Page easier to find" would be great.

Then we can have more contributors come up with creative ways to improve this.

Thank you.

#2 @ocean90
7 weeks ago

  • Component changed from Administration to Posts, Post Types
  • Focuses administration added
  • Keywords reporter-feedback removed
  • Summary changed from Admin search sucks to Make front/blog/privacy page easier to find in posts list table

#3 @scienceofspock
7 weeks ago

@valentinbora Thanks for the reply, it looks like someone has already changed the title.

#4 @zodiac1978
5 weeks ago

I had this problem too and found a solution on StackExchange:
https://gist.github.com/Zodiac1978/ced81b9a46dcd55d2701829deec912b7

Maybe this could be used in core?

Last edited 5 weeks ago by zodiac1978 (previous) (diff)

#5 @zodiac1978
5 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39666.

Note: See TracTickets for help on using tickets.