WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4947 closed defect (bug) (fixed)

get_categories() does not preverve backward compatibility

Reported by: mdawaffe Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch commit
Focuses: Cc:

Description

[5818] adds backward compatibility for category objects and arrays, but it doesn't catch in get_categories(). Annoyingly, references can't work like that in PHP 4 foreach loops.

Patch attached

Attachments (1)

4947.diff (466 bytes) - added by mdawaffe 7 years ago.

Download all attachments as: .zip

Change History (3)

mdawaffe7 years ago

comment:1 ryan7 years ago

Ah, it's a php4 thing. No wonder I couldn't reproduce the prob.

comment:2 ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.