WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#49498 closed enhancement (duplicate)

Consider adding a pull_request_template.md to point GitHub contributors to the right place

Reported by: noisysocks Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: docs Cc:

Description

Now that you can link pull requests to Trac tickets in Core, we should consider adding a pull_request_template.md to trunk which informs contributors who land on the wordpress-develop GitHub repository that pull requests must be linked to a Trac ticket.

The template could look something like this:

<!--
Hi there! Thanks for contributing to WordPress!

WordPress uses Trac and SVN for development. Pull requests in this GitHub repository are only used for code review, and must be linked to a ticket in the WordPress Core Trac (https://core.trac.wordpress.org).

See the WordPress Core Handbook for more information: 

LINK TO HANDBOOK PAGE
-->

Trac: <!-- insert a link to the WordPress Core Trac ticket here -->

<!-- insert a short description of your changes here -->

---

**This pull request is for code review only. Please keep all other discussion in the Trac ticket. Do not merge this Pull Request. See [the WordPress Core Handbook](LINK TO HANDBOOK PAGE) for more details.**

Change History (2)

#1 @kraftbj
8 months ago

  • Keywords 2nd-opinion needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #49489 resolved via r47342.

#2 @noisysocks
8 months ago

Doh, Jonathan beat me to it! 🤦‍♂️ Thanks @kraftbj.

Note: See TracTickets for help on using tickets.