WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#49506 closed defect (bug) (fixed)

Block Editor: Update WordPress Packages WordPress 5.4 Beta 3.

Reported by: jorgefilipecosta Owned by: jorgefilipecosta
Milestone: 5.4 Priority: normal
Severity: normal Version: 5.4
Component: Editor Keywords: has-patch
Focuses: Cc:

Description

The following package versions were changed:
@wordpress/block-directory: 1.5.1 -> 1.5.2
@wordpress/block-editor: 3.7.1 -> 3.7.2
@wordpress/block-library: 2.14.1 -> 2.14.2
@wordpress/components: 9.2.1 -> 9.2.2
@wordpress/edit-post: 3.13.1 -> 3.13.2
@wordpress/editor: 9.12.1 -> 9.12.2
@wordpress/format-library: 1.14.1 -> 1.14.2
@wordpress/list-reusable-blocks: 1.13.1 -> 1.13.2
@wordpress/media-utils: 1.7.1 -> 1.7.2
@wordpress/nux: 3.12.1 -> 3.12.2
@wordpress/server-side-render: 1.8.1 -> 1.8.2

Attachments (2)

49506.diff (28.3 KB) - added by jorgefilipecosta 3 months ago.
49506-script-assets.php (17.3 KB) - added by aduth 3 months ago.

Download all attachments as: .zip

Change History (9)

#1 @jorgefilipecosta
3 months ago

  • Owner set to jorgefilipecosta
  • Resolution set to fixed
  • Status changed from new to closed

In 47354:

Block Editor: Update WordPress Packages WordPress 5.4 Beta 3.

The following package versions were changed:
@wordpress/block-directory: 1.5.1 -> 1.5.2
@wordpress/block-editor: 3.7.1 -> 3.7.2
@wordpress/block-library: 2.14.1 -> 2.14.2
@wordpress/components: 9.2.1 -> 9.2.2
@wordpress/edit-post: 3.13.1 -> 3.13.2
@wordpress/editor: 9.12.1 -> 9.12.2
@wordpress/format-library: 1.14.1 -> 1.14.2
@wordpress/list-reusable-blocks: 1.13.1 -> 1.13.2
@wordpress/media-utils: 1.7.1 -> 1.7.2
@wordpress/nux: 3.12.1 -> 3.12.2
@wordpress/server-side-render: 1.8.1 -> 1.8.2

Fixes #49506.

#2 @ocean90
3 months ago

  • Milestone changed from Awaiting Review to 5.4
  • Resolution fixed deleted
  • Status changed from closed to reopened

/src/wp-includes/assets/script-loader-packages.php was not updated, see [47352].

This ticket was mentioned in Slack in #core by ocean90. View the logs.


3 months ago

#4 @SergeyBiryukov
3 months ago

  • Component changed from General to Editor

#5 @aduth
3 months ago

49506-script-assets.php is the local diff I see after running npx grunt build:webpack on the current trunk, which I expect is what needs to be committed.

#6 @SergeyBiryukov
3 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 47377:

Block Editor: Update wp-includes/assets/script-loader-packages.php.

Follow-up to [47352], [47354].

Props aduth, ocean90, garrett-eclipse.
Fixes #49506.

This ticket was mentioned in PR #174 on WordPress/wordpress-develop by jorgefilipecosta.


3 months ago

The following package versions were changed:
@wordpress/annotations: 1.12.0 -> 1.12.1
@wordpress/block-directory: 1.5.2 -> 1.5.3
@wordpress/block-editor: 3.7.2 -> 3.7.3
@wordpress/block-library: 2.14.2 -> 2.14.3
@wordpress/blocks: 6.12.0 -> 6.12.1
@wordpress/components: 9.2.2 -> 9.2.3
@wordpress/core-data: 2.12.0 -> 2.12.1
@wordpress/data: 4.14.0 -> 4.14.1
@wordpress/data-controls: 1.8.0 -> 1.8.1
@wordpress/edit-post: 3.13.2 -> 3.13.3
@wordpress/editor: 9.12.2 -> 9.12.3
@wordpress/format-library: 1.14.2 -> 1.14.3
@wordpress/keyboard-shortcuts: 1.1.0 -> 1.1.1
@wordpress/list-reusable-blocks: 1.13.2 -> 1.13.3
@wordpress/notices: 2.0.0 -> 2.0.1
@wordpress/nux: 3.12.2 -> 3.12.3
@wordpress/priority-queue: 1.5.0 -> 1.5.1
@wordpress/rich-text: 3.12.0 -> 3.12.1
@wordpress/server-side-render: 1.8.2 -> 1.8.3
@wordpress/viewport: 2.13.0 -> 2.13.1

Ticket: https://core.trac.wordpress.org/ticket/49506

Note: See TracTickets for help on using tickets.