WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#4952 closed enhancement (duplicate)

jQuery 1.2

Reported by: ev3rywh3re Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: jquery has-patch needs-testing
Focuses: Cc:

Description

jQuery 1.2 is out, but I'm sure y'all will want to pick at it first. I could understand if it wouldn't make it into WordPress 2.3.

http://docs.jquery.com/Release:jQuery_1.2

Attachments (1)

4952.diff (48.5 KB) - added by Nazgul 8 years ago.

Download all attachments as: .zip

Change History (10)

@Nazgul8 years ago

comment:1 @Nazgul8 years ago

  • Keywords has-patch needs-testing added

comment:2 @DD328 years ago

patch missed wp-includes/script-loader.php version

comment:3 follow-up: @JeremyVisser8 years ago

Sweet, there's a colour animation plugin (in the form of jQuery.animate()) that we can use to do away with FAT. (I've heard FAT has some problems, and would be fitting with #3824.)

comment:4 @zamoose8 years ago

  • Milestone changed from 2.3 to 2.4 (next)
  • Version 2.3 deleted

This is definitely a 2.4 sort of thing, no way it should touch 2.3.

comment:5 @ev3rywh3re8 years ago

I thought it may be good to note that the UI jQuery plugin that will probably be a nice replacement for Interface is scheduled for release on Sunday, September 16, 2007.

http://jquery.com/blog/2007/09/10/jquery-12-jqueryextendawesome/

comment:6 in reply to: ↑ 3 @Viper007Bond8 years ago

Replying to JeremyVisser:

Sweet, there's a colour animation plugin (in the form of jQuery.animate()) that we can use to do away with FAT. (I've heard FAT has some problems, and would be fitting with #3824.)

Holy crap, that is some sweet stuff: http://dev.jquery.com/~john/ticket/fx-rewrite2/

comment:7 @intoxination8 years ago

I played with 1.2 for a long time yesterday. The only problem I have noticed (which is somewhat a major one) is in the widgets. On IE7 the widget options breaks. You click the button and nothing happens. That is something that will have to be fixed before changing over to 1.2. It works fine in FF though.

The new UI is very nice. I been playing with it a lot for the past few weeks. Something that might be worth looking at is changing the DBX boxes over to it (they suck in IE and are essentially useless). I actually started it using interface a few months ago but got sidetracked. I'll look into how much work it will be and open a ticket if it is viable.

comment:8 @zamoose7 years ago

Shall we move this to 1.2.1, seeing as it's the one that's out currently?

comment:9 @zamoose7 years ago

  • Milestone 2.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

A numerical anagram of this ticket (#5492 -- weird, huh?) has been opened and has a more recent patch associated with trunk. I suggest closing this one out.

Note: See TracTickets for help on using tickets.