WordPress.org

Make WordPress Core

Opened 6 weeks ago

Last modified 4 weeks ago

#49524 new defect (bug)

Selecting then formatting often does not work.

Reported by: programmin Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.3.2
Component: Editor Keywords: reporter-feedback
Focuses: ui, javascript Cc:

Description

I've noticed a bug most times I've tried formatting within the new Gutenberg editor paragraph. You can usually see it in 3 steps:

  1. Open an editor, new post and just start a paragraph with "one two three" or something.
  2. Select from right to left select all the text.
  3. Click "I" then "B", italic and bold.

It doesn't format all of it but the right most part, sometimes just the rightmost letter?? Why?

Happens with the latest Gutenberg plugin enabled or disabled. This is Ubuntu with Firefox 73 if that matters.

Change History (3)

#1 @afercia
5 weeks ago

  • Keywords reporter-feedback added

Hello @programmin and thanks for your report. I wasn't able to reproduce this issue, tested on macOS Firefox 73.

Does it still happen with all plugins disabled and a default theme (for example Twenty Twenty or Twenty Nineteen) activated?

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


4 weeks ago

#3 @afercia
4 weeks ago

  • Focuses accessibility removed

This ticket was discussed during today's accessibility bug-scrub: agreed to remove the accessibility focus, as this issue doesn't appear strictly related to web accessibility.

To help the editor team, it would be great to provide clearer steps to reproduce. I wasn't able to reproduce on a clean trunk installation.

Note: See TracTickets for help on using tickets.