WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 9 months ago

Last modified 9 months ago

#49551 closed defect (bug) (worksforme)

When editing a post date with some locales, the date format of month would shows wrong one.

Reported by: tai Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4
Component: Editor Keywords:
Focuses: javascript Cc:

Description

When editing a post date with some locales, the date format of month would shows wrong one.

It happens only when using the classic editor functions in the core, and the Gutenberg editor shows the right date format.

Step to reproduce:

  1. Install the classic editor and activate it.
  2. Select "日本語" (Japanese) at "Site Language" option.
  3. Open an edit screen of any post.
  4. Now the Published date (in ja "投稿日") string looks like "2020年2月12日"(bug-1.png)
  5. Click "編集"(Edit) at "投稿日" in Publish block.
  6. Select any month of NOT current one and click the OK button.
  7. Now the Published date string looks like "2020年1月月12日"(bug-2.png), inserted the unnecessary month suffix of Japanese "月".

How to fix:

I've dug into the source and found it happens around the below but no idea how to fix so far:
https://github.com/WordPress/WordPress/blob/master/wp-admin/js/post.js#L762-L772

Version:
I've checked it on WordPress 5.4-beta3 and WordPress 5.3.2

Attachments (2)

bug-1.png (55.1 KB) - added by tai 11 months ago.
right month string.
bug-2.png (60.1 KB) - added by tai 11 months ago.
wrong month string.

Download all attachments as: .zip

Change History (5)

@tai
11 months ago

right month string.

@tai
11 months ago

wrong month string.

#1 @tai
11 months ago

I've just confirmed it doesn't happen on WordPress 5.2.4, so I guess it was introduced after WordPress 5.3.

#2 @tai
9 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Ah, it caused by the wrong translation. I've submitted the right translation.
https://translate.wordpress.org/projects/wp/dev/ja/default/?filters%5Btranslated%5D=yes&filters%5Bstatus%5D=waiting

Last edited 9 months ago by SergeyBiryukov (previous) (diff)

#3 @SergeyBiryukov
9 months ago

  • Milestone Awaiting Review deleted

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.