WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#49579 closed defect (bug) (worksforme)

#wpadminbar lost in new 5.4 fullscreen editor

Reported by: jsmoriss Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4
Component: Editor Keywords:
Focuses: Cc:

Description

The WordPress "#wpadminbar", which many plugins use to provide information and notices about the current post, is no longer shown when using the 5.4 fullscreen editor (which is the default), and there does not seem to be any setting for turning it back on!

js.

Attachments (1)

toggle-mode.png (64.9 KB) - added by ocean90 20 months ago.

Download all attachments as: .zip

Change History (8)

#1 @jsmoriss
20 months ago

Here's a quick-fix that I had to implement:

/**
 * Fix the WordPress v5.4 fullscreen editor.
 */
body.wp-admin.is-fullscreen-mode #wpadminbar {
        display:block;
}

body.wp-admin.is-fullscreen-mode .block-editor__container {
        min-height: calc(100vh - 32px);
}

body.wp-admin.is-fullscreen-mode .block-editor-editor-skeleton {
        top:32px;
}

js.

@ocean90
20 months ago

#2 @ocean90
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

You can disable the fullscreen view by clicking again on "Fullscreen mode" in the view settings.

For more information see https://make.wordpress.org/core/2020/03/03/fullscreen-mode-enabled-by-default-in-the-editor/.

#3 @jsmoriss
20 months ago

I'm not sure why that image was added - the "Top toolbar" for the editor is not the same as the WordPress "#wpadminbar" top toolbar. Enabling the editor "Top toolbar" does not re-enable the WordPress top toolbar.

The problem is not the fullscreen editor, it's that the fullscreen editor does not show the WordPress top toolbar, which is required by many plugins to show contextual information and notices.

js.

#4 @jsmoriss
20 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Here is the difference:

https://surniaulula.com/wp-content/uploads/fullscreen-no-wpadminbar.png

https://surniaulula.com/wp-content/uploads/fullscreen-with-wpadminbar.png

js.

#5 @ocean90
20 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

That’s just the focus outline what you’re seeing there with regards to the top toolbar.

The admin bar is probably one of the distracting items when writing a post, that’s likely why it was decided to hide it in the full screen/non-distracting mode.

#6 @jsmoriss
20 months ago

Since there is no usable notification system at the moment (ie. the visual editor notices do not allow HTML to link solutions etc.) then the only viable location for notices and current post information is the top toolbar.

js.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


20 months ago

Note: See TracTickets for help on using tickets.