WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 6 weeks ago

#49604 closed enhancement (fixed)

Privacy hooks and documentation

Reported by: arena Owned by:
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: Privacy Keywords:
Focuses: docs Cc:

Description

This is more a documentation issue :

It is very hard to see at a glance all the hooks set up inside wordpress related to privacy

Maybe i didn't look at the right sites or pages

I know that some others are also used for privacy purpose but digging in all the blog posts, release notifications, trac tickets and external forums such as slack is a real pain ...

Hereattached are the hooks in 5.4RC with the word 'privacy' in it.

Attachments (1)

privacy hooks in wp54rc.pdf (14.8 KB) - added by arena 9 months ago.
privacy hooks in wp54rc

Download all attachments as: .zip

Change History (8)

@arena
9 months ago

privacy hooks in wp54rc

#1 @carike
9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

The developer site is under the control of the Documents team.
The search function is under the control of the Meta team.

Trac tickets for Core are intended for proposed changes to the code included in WordPress releases.

#2 follow-up: @garrett-eclipse
8 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to fixed

Thanks for the list @arena after getting an update to the Plugin Handbook done I conferred to it and caught a couple more.

The official handbook page;
https://developer.wordpress.org/plugins/privacy/privacy-related-options-hooks-and-capabilities/

Note: From your list blog_privacy_selector, privacy_on_link_text and privacy_on_link_title are actually for the blog seo privacy (hide from robots checkbox) so I've left them off of the list.

Cheers

#3 in reply to: ↑ 2 ; follow-up: @arena
8 months ago

Thank you for the reply (and the documentation link)

The list is just from hooks with 'privacy' in it. i was not sure that they were all listed.
I use this kind of list with xref code to dig into the wordpress code (https://blog.mailpress.org/hooks/wordpress/)

I am currently working on my plugin GDPress (stuck at home in France since March 17th).
Making big changes and am currently looking for a way to track all events related to privacy.

I saw you are following some (not all) of my tickets.

i wrote #49661 + patch to have an option to track mails from privacy (at least privacy team could be an early adopter - making some promotion of my work :-D ) . Maybe there are workarounds.
i was also willing to trap when privacy request zip files are downloaded. I don't know if the link provided by mail is filterable, if not this can be an issue.

and of course ... #49627, #49602

hope you are well

Stay At Home !

Replying to garrett-eclipse:

Thanks for the list @arena after getting an update to the Plugin Handbook done I conferred to it and caught a couple more.

The official handbook page;
https://developer.wordpress.org/plugins/privacy/privacy-related-options-hooks-and-capabilities/

Note: From your list blog_privacy_selector, privacy_on_link_text and privacy_on_link_title are actually for the blog seo privacy (hide from robots checkbox) so I've left them off of the list.

Cheers

#4 @SergeyBiryukov
8 months ago

  • Focuses docs added
  • Milestone set to WordPress.org

#5 in reply to: ↑ 3 ; follow-up: @garrett-eclipse
8 months ago

Replying to arena:

i was also willing to trap when privacy request zip files are downloaded. I don't know if the link provided by mail is filterable, if not this can be an issue.

The wp_privacy_personal_data_email_content filter and the ###LINK### tag will allow you to filter the URL in the email.
The wp_privacy_exports_dir and wp_privacy_exports_url filter the directory used and URL of the directory used to store personal data export files.

Stay safe.

#6 in reply to: ↑ 5 @arena
8 months ago

Replying to garrett-eclipse:

Did you miss these ones in https://developer.wordpress.org/plugins/privacy/privacy-related-options-hooks-and-capabilities/ ?

apply_filters( 'user_erasure_fulfillment_email_to', ...
apply_filters( 'user_erasure_complete_email_subject', ...
apply_filters( 'user_confirmed_action_email_content', ...
apply_filters( 'user_erasure_complete_email_headers', ...

Last edited 8 months ago by arena (previous) (diff)

#7 @garrett-eclipse
6 weeks ago

  • Focuses privacy removed

Dropping privacy focus as it's already in the Privacy component.

Note: See TracTickets for help on using tickets.