WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#49646 closed defect (bug) (invalid)

Twenty Twenty: There are some Missing Pages on any new installation of WordPress.

Reported by: mari3000 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: administration Cc:

Description

I have found an issue of installing a newly WordPress package.

I have experienced this issue both at local and remote installation. And even it happened on another computer.

(My condition: I use a hosted server with a cPanel. And I use Local by Flywheel app for local installation. )

Anyway the problem is the following.
The newly installed WordPress sites don’t have the all default pages of the default theme TwentyTwenty.

Two weeks ago, I installed a WordPress package on a hosted server and it had default theme TwentyTwenty as perfect state.
That is, it had some pages more than only two page.

Then it was more than one weeks ago, I installed a newly WordPress on the same server.
And I noticed that the newer installed WordPress did have only two pages as it first state.
One is "Sample Page" and one is "Privacy Policy" page.
I think it’s abnormal.

But at that point, I copied the missing pages from the normal WordPress package, and pasted them to the newer package, then started working on the site.

But yesterday I found that all the new installation of WordPress have only two pages par site.
Each new site has only two pages, "Sample page" and "Privacy Policy" page.

This is a screenshot.
https://drive.google.com/file/d/1s-PCcy-33OqraUTnMZhjCfZgYXW1mFyb/view?usp=sharing

If you remember the original state of TwentyTwenty, you can understand that it’s abnormal.

I customised my older sites so I now can’t say how many pages were originally included in TwentyTwenty.
But I searched and found that the default TwentyTwenty has at least two more pages(=total over 4 pages).
One missing page is "The New UMoMA Opens its Doors", and one is the "Contact" page. Newer installations at both local and hosted server don’t include these pages.

And I remember there was an abstract red coloured image in Media Library as default state until two weeks ago. But these newer installed site does not have that image in Media Library.

Why I am reporting this to WordPress instead of TwentyTwenty theme because when I change the theme from TwentyTwenty to other past default themes which created by WordPress, each site also has only two pages instead of more pages. And I think it’s abnormal.

And I also changed theme from TwentyTwenty to other theme made by third party(but I installed it via Themes Page).
Then using demo-installer I brought the many page in the theme as originally designed by the third party team and it seems there is not problem there.

So it seems that this issue is exist only when we use current and past default WordPress themes.
While it seems there is not any visible problem with using third party themes, but I don't want to use WordPress until the default state is clearly fixed.

Thank you for reading. And I wish this issue would be solved very soon. As I'd like to make some new sites very soon.

Change History (3)

#1 follow-up: @carike
12 months ago

  • Component changed from General to Bundled Theme
  • Resolution set to invalid
  • Status changed from new to closed

Hallo :)

"The New UMoMA Opens its Doors" is part of TwentyTwenty starter content.
The way that starter content needs to be treated is a matter that has been under consideration for a while.

When on a fresh install, please go to /wp-admin/, Appearance, Customizer.
If you click on Publish, you should now see the starter content.

The starter content for TwentyTwenty is included under inc -> starter-content.php in the theme files.

Going to close this ticket for now, as this appears to be intended behaviour.
It can be re-opened if necessary.

#2 in reply to: ↑ 1 @mari3000
12 months ago

Replying to carike:

Hallo :)

"The New UMoMA Opens its Doors" is part of TwentyTwenty starter content.
The way that starter content needs to be treated is a matter that has been under consideration for a while.

When on a fresh install, please go to /wp-admin/, Appearance, Customizer.
If you click on Publish, you should now see the starter content.

The starter content for TwentyTwenty is included under inc -> starter-content.php in the theme files.

Going to close this ticket for now, as this appears to be intended behaviour.
It can be re-opened if necessary.

Oh! Thank you so much for letting me know it! And I'm very sorry that I made this ticket and bother you.
Have a lovely day @carike ! :)

#3 @SergeyBiryukov
12 months ago

  • Milestone Awaiting Review deleted
  • Summary changed from There are some Missing Pages on any new installation of WordPress. to Twenty Twenty: There are some Missing Pages on any new installation of WordPress.
Note: See TracTickets for help on using tickets.