WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#49726 closed defect (bug) (invalid)

Featured image reverts to default when publishing post

Reported by: psiegel Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Post Thumbnails Keywords:
Focuses: Cc:

Description

I don't know when exactly this started, if it's due to a theme or plugin, but these days whenever I author a new post and assign a featured image, it reverts to the site's default featured image. I can then update the featured image after publishing, but I use Jetpack's publicize feature to automatically share new posts to Twitter and Facebook, and thus they get the wrong featured image.

The work around I've employed is to always schedule my posts for a few minutes in the future. I can then go back and fix the featured image before the posts goes public, and thus it will publish with the correct image. This is a serious pain though. It sure would be nice if the publish button would stop reverting my featured image to the default!

Change History (1)

#1 @knutsp
2 months ago

  • Component changed from General to Post Thumbnails
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.3.2 deleted

Hello, @psiegel and welcome to Trac!

Sorry to hear you have trouble with WordPress. Please be aware that this Trac is for reporting bugs and suggest enhancements and features for the core software, and specifically not for support questions.

WordPress core has no concept of default featured image. It's most probably a plugin issue or plugin conflicts.

I suggest you seek help with this issue through our support forums https://wordpress.org/support/forums/

I close this ticket for now. If you after all still think this is a bug in WordPress, please come back and reopen this ticket, while adding exacts steps to reproduce from a clean install (no plugins and a default theme).

Note: See TracTickets for help on using tickets.