Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#49771 closed defect (bug) (duplicate)

Double Updated! text blocks when updating theme

Reported by: bookdude13's profile bookdude13 Owned by: whyisjake's profile whyisjake
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Themes Keywords: needs-patch
Focuses: Cc:

Description

When updating a theme in single site, there is a way to make two Updated! blocks appear after the update is completed. Reproduction:
1) Go to wp-admin/themes.php
2) Update a theme from the main page (where all themes listed) by clicking the link in the notification above the theme.
3) While it is still updating, click the theme to open the details overlay.
4) Note that after updating another notification block spawns with the Updated! text.

Attachments (1)

double_update_text.PNG (105.7 KB) - added by bookdude13 4 years ago.
Double update text

Download all attachments as: .zip

Change History (7)

@bookdude13
4 years ago

Double update text

#1 @whyisjake
4 years ago

  • Milestone changed from Awaiting Review to 5.5
  • Owner set to whyisjake
  • Status changed from new to accepted
  • Version set to trunk

#2 @whyisjake
4 years ago

I'm having a hard time checking this. It feels like after clicking the update button, it locks the UI to get to the theme details, and I can't click the second button. Can anyone else confirm?

#3 @pbiron
4 years ago

I can't replicate either...for the same reason: while the theme is updating, clicking on "Theme Details" doesn't open the modal.

However, I've looked through the JS (wp-admin/js/theme.js and wp-admin/js/updates.js) and can't figure out what prevents that :-(

#4 @whyisjake
4 years ago

@azaozz can you confirm?

#5 @whyisjake
4 years ago

  • Milestone 5.5 deleted
  • Resolution set to worksforme
  • Status changed from accepted to closed

Looks like we are good here then! Feel free to update as needed.

#6 @SergeyBiryukov
3 years ago

  • Resolution changed from worksforme to duplicate

Duplicate of #41341.

Note: See TracTickets for help on using tickets.