WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 5 months ago

#49786 closed enhancement (duplicate)

Add first and last name to add new user form on multisite

Reported by: andyburnsco Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4
Component: Users Keywords:
Focuses: multisite Cc:

Description

When creating users on multisite, you only get to add their username and email (user-new.php template > add new user). On single site installs, users can add first name, last name and website. (user-new.php)

On multisite at /wp-admin/user-new.php, it should allow for the first and last name fields to the Add New User form.

Is there a reason for this difference? For WP sites that have CRM integration, not getting core fields of a contact makes adding a user more difficult. Namely, duplicates are created. It is most important to have these fields available on each site not just the network level user creation form at /wp-admin/network/user-new.php.

Ref: https://premium.wpmudev.org/forums/topic/multisite-first-and-last-name-when-add-new-user/

Change History (2)

#1 @andyburnsco
8 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18163.

#2 @desrosj
5 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.