WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 5 months ago

#49823 closed defect (bug) (duplicate)

WP_Customize_Cropped_Image_Control Default Image Doesn't Display

Reported by: Schwarttzy Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Customize Keywords: needs-patch
Focuses: Cc:

Description

I've been wanting to use the customizer control WP_Customize_Cropped_Image_Control in my theme for years. However, the default image needs to have an attachment ID to work in WP_Customize_Cropped_Image_Control. Whereas the customizer control WP_Customize_Image_Control just uses an URL to display the image.

When developing a theme the author is left in a conundrum because they cannot have a default image display without adding the image to the database. However, that in itself would be ill-advised because theme developers are not allowed to mess with the database unless the user chooses the theme mod option.

Is there something I'm missing? Could WP_Customize_Cropped_Image_Control be made to display a simple URL for the default image?

Change History (4)

#1 follow-up: @dlh
13 months ago

  • Keywords reporter-feedback added
  • Severity changed from major to normal
  • Version changed from 5.4 to 4.2

Hi @Schwarttzy, and welcome to Trac!

I see that you also found and commented on #42075. Would it be safe to say that that ticket describes the same issue or pretty close to it?

#2 in reply to: ↑ 1 @Schwarttzy
13 months ago

Replying to dlh:

Hi @Schwarttzy, and welcome to Trac!

I see that you also found and commented on #42075. Would it be safe to say that that ticket describes the same issue or pretty close to it?

Yes, the same problem.

#3 @dlh
13 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks! In that case, I'm going to mark this ticket as a duplicate of #42075 so that we can keep the conversation in one place.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


5 months ago

Note: See TracTickets for help on using tickets.