WordPress.org

Make WordPress Core

#49935 closed defect (bug) (invalid)

Copy the Permalink does nothing in Safari

Reported by: yroca23 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3.2
Component: Editor Keywords:
Focuses: Cc:

Description

In Chrome, copy the permalink above Post Title when editing a post works. When you try same operation from Safari browser, nothing is copied to the clipboard. I verify this by pasting and whatever happened to be on my clipboard prior is pasted.

Attachments (1)

Screen Shot 2020-04-17 at 12.08.30 PM.png (50.8 KB) - added by yroca23 20 months ago.
Screenshot of the Copy the Permalink button I am referring to.

Download all attachments as: .zip

Change History (4)

@yroca23
20 months ago

Screenshot of the Copy the Permalink button I am referring to.

#1 @SergeyBiryukov
20 months ago

  • Component changed from Posts, Post Types to Editor

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


12 months ago

#3 @talldanwp
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @yroca23, Thanks for reporting this and sorry for the lack of reply. For the future, Block Editor issues are reported over in the Gutenberg github repository:
https://github.com/WordPress/gutenberg/issues

The UI for permalinks has since moved to the Document settings in the editor sidebar, and the copy button was removed as part of that change (the link text can be right-clicked and copied), so I'll close this ticket.

Note: See TracTickets for help on using tickets.