WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 4 months ago

#49946 closed defect (bug) (invalid)

Twenty Seventeen: Missing Theme Options

Reported by: carstenarenz Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Hello,

I have found some related topics but none with anything near a solution.

I upgraded a website to “Twenty Seventeen” Theme and was able to assign 5 pages to the front sections. But know this option vanished, so I cannot change anything anymore. The “Theme Options” Button is completely missing. Also missing are the little blue pencil icons in the previews and the option to add a video to the header.

I have set a static home page and also set the option to display it.

I do not have too many plugins installed and for sure none was added between setting the sections and no not being able to do anymore.

The only thing I did, not sure if this was in between the two timestamps, was updating from WP 4.9 to latest 5.4.

I did delete the theme, reinstalled it, no luck.

Any help is much appreciated.

Carsten

Change History (10)

#1 @SergeyBiryukov
6 months ago

  • Component changed from General to Bundled Theme
  • Summary changed from Missing Theme Options in Theme Twenty Seventeen to Twenty Seventeen: Missing Theme Options

#2 @piyushmca
6 months ago

  • Focuses template added
  • Resolution set to invalid
  • Status changed from new to closed

Hi,

after update theme i think your plugin conflicts to your theme. try deactivate your plugin and then after check.

Thanks,
@piyushmca

#3 follow-up: @carstenarenz
6 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

But I was able to set the options with the plugins active. I disabled all plugins and the problem stays.

#4 in reply to: ↑ 3 ; follow-up: @piyushmca
6 months ago

Replying to carstenarenz:

But I was able to set the options with the plugins active. I disabled all plugins and the problem stays.

Some time its happen you update word press and plugin are old or theme is old then error is accrue..

#5 in reply to: ↑ 4 @carstenarenz
6 months ago

Replying to piyushmca:

Replying to carstenarenz:

But I was able to set the options with the plugins active. I disabled all plugins and the problem stays.

Some time its happen you update word press and plugin are old or theme is old then error is accrue..

And how do I fix it?

#6 @knutsp
6 months ago

  • Focuses template removed
  • Resolution set to invalid
  • Status changed from reopened to closed

Hello @carstenarenz, welcome to Trac and thanks for the ticket.

Please observe that this Trac is a tool for tracking bugs and enhancements in the core software, not for support or help with individual sites.

Your problem seems to me, after a quick search, to explained here: https://wordpress.org/support/topic/missing-theme-options-twenty-seventeen/

If this does not explain or fix your problem, please create a new topic on https://wordpress.org/support/forums/

If it then turns out this is probably due to a core bug, including in this bundled theme, please come back and re-open this ticket with detailed steps to reproduce the problem.

Last edited 6 months ago by knutsp (previous) (diff)

#7 follow-up: @carstenarenz
6 months ago

I basically found all these topics explaining about Staic Homepage and multiple pages, this is all set - in fact it did work to set the different pages up and now the option has vanished. So the question is, what makes the Theme think that the option should not be displayed.

#8 in reply to: ↑ 7 @knutsp
6 months ago

Replying to carstenarenz:

what makes the Theme think that the option should not be displayed.

Still a support question. Docs says:

This option is available on all pages. It's also available on archives when there isn't a sidebar.

Please use the support forum for further questions.

#9 @carstenarenz
6 months ago

There is no sidebar, in fact the page displays the 5 sections I was able to setup once.

https://www.casaangelieri.com/home-2

I cannot change it anymore, nor can I reach the option to replace the first image by a video.

#10 @desrosj
4 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.