WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5002 closed defect (bug) (duplicate)

Apostrophes in blog title wrongly escaped

Reported by: jrawle Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.3
Component: General Keywords: title character escape apostrophe "single quote"
Focuses: Cc:

Description

If the title of the weblog contains an apostrophe, the apostrophe is prefixed with a backslash whenever the "General options" are updated.

For example, if your title is John's Blog, this becomes John\'s Blog.

Removing the backslash doesn't work as it is simply added again.

A work-around is to enter the apostrophe as a smart quote or as the entity ’
This is how apostrophes are always displayed anyway. However, this is not very user-friendly, and people who aren't in the know would not think to try it.

Change History (2)

comment:1 @ryan8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #4949

comment:2 @Stevie2128 years ago

This is fixed actually for 2.2 branch. Although since 2.3 gets released in 6 days it doesn't matter. Also 2.3 doesn't suffer this problem thankgod.

Note: See TracTickets for help on using tickets.