WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#50039 closed enhancement (fixed)

Add a command for restarting the Docker development environment

Reported by: desrosj Owned by: desrosj
Milestone: 5.5 Priority: low
Severity: trivial Version: 5.3
Component: Build/Test Tools Keywords: has-patch
Focuses: Cc:

Description

When making adjustments locally, it's not uncommon to have to stop and start the local Docker environment. Right now, it requires typing two commands. It would be great to have an npm run env:restart command to simplify this.

Attachments (1)

50039.diff (620 bytes) - added by desrosj 18 months ago.

Download all attachments as: .zip

Change History (10)

@desrosj
18 months ago

#1 @desrosj
18 months ago

  • Type changed from defect (bug) to enhancement

#2 @ianbelanger
18 months ago

  • Keywords commit added

Just tested the new command and it works as intended. I think it will be a great addition to the Docker development environment.

#3 @desrosj
18 months ago

  • Keywords fixed-major added

Committed in [47728]. This should get backported to the other branches that have the Docker environment. Going to leave this open.

#4 @desrosj
18 months ago

In 47729:

Reverting [47728].

Unprops desrosj.
See #50039.

#5 @desrosj
18 months ago

  • Owner set to desrosj
  • Resolution set to fixed
  • Status changed from new to closed

In 47730:

Build/Test Tools: Introduce a command for restarting the local Docker environment.

This change introduces the env:restart command for easier restarting of the local Docker environment.

Props desrosj, ianbelanger.
Fixes #50039.

#6 @desrosj
18 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#7 @desrosj
18 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 47731:

Build/Test Tools: Introduce a command for restarting the local Docker environment.

This change introduces the env:restart command for easier restarting of the local Docker environment.

Merges [47730] to the 5.4 branch.

Props desrosj, ianbelanger.
Fixes #50039.

#8 @desrosj
18 months ago

In 47732:

Build/Test Tools: Introduce a command for restarting the local Docker environment.

This change introduces the env:restart command for easier restarting of the local Docker environment.

Merges [47730] to the 5.3 branch.

Props desrosj, ianbelanger.
Fixes #50039.

#9 @desrosj
18 months ago

  • Keywords commit fixed-major removed

Closing this out as it's now in every branch with the local Docker environment. This can be backported further in #48301.

Note: See TracTickets for help on using tickets.