WordPress.org

Make WordPress Core

#50112 closed feature request (duplicate)

I18N - Option to set a fallback language

Reported by: arglab Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:

Description

It would be great if WordPress had an option to select which language to use when translations are not available in a locale. Currently, if a translation is not available, WordPress displays the string in English.

This is one of the main reasons why many people who create projects for users who speak a Spanish dialect prefer to use es_ES instead of their locale. Using es_AR as an example, it would be great that, if a user selects es_AR for their site, the translations made for that locale have priority, but if some translations are not available, the site uses es_ES instead of en_US.

The current solutions are:

  • To manually download the translations of es_ES, and upload them to the /languages​​/ folder. However this process is tedious, and I doubt the average user knows how to do it.
  • Use a plugin like Language Fallback.

Including this functionality in the core would increase the use of locales with fewer translations that derive from bigger locales, like es_X, de_X, pt_X and fe_X.

The language fallback option could be conditional to the selected language:

https://i.imgur.com/mDSOOjR.gif

Change History (2)

#1 @ocean90
11 months ago

  • Milestone Awaiting Review deleted

Hello @arglab, welcome to WordPress Trac!

Thanks for the ticket. We're already tracking this request in #28197.

Maybe take a look at Preferred Languages if you haven't yet.

#2 @SergeyBiryukov
11 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28197.

Note: See TracTickets for help on using tickets.