WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5018 closed defect (bug) (invalid)

WP 2.2.2 Mis-Handles the Home page and Contact Post

Reported by: misty9 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.2
Component: Template Keywords:
Focuses: Cc:

Description

Problem Description:

Word Press 2.2.2 lists unintended Contact post on to the existing Home page. i.e The Home page would have two sections: 1. Hello World page 2. Contact post. This specific problem defintiely does NOT happen with exact same Word Press themes in Word Press 2.2.

Word Press Functions:
The following code has triggered the problem in displaying Home page and Contact post:

<title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?></title>

(I have report the problem below as well:
http://wordpress.org/support/topic/134574?replies=1#post-617281)

Steps to Reproduce the Problem:

  1. Install Word Press 2.2.2 (which was the available version at Lunnarpages.com)
  2. Drop in any Word Press theme that has a Contact post.

Try WP themes like Connections-10, Green bug 10 or Pro-sunset.

I hope that you guys can fix the problem very soon. Thanks.

Change History (11)

comment:1 @markjaquith7 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Contact pages should be made using the "Page" functionality of WordPress, not the "Post" functionality. It is intended for all posts to show up on your "home" view.

comment:2 @misty97 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

How can you close the bug without even understand the true issue here?

I have not done anything to the Word Press Themes, not creating any post or pages.

Steps to Reproduce the Problem: 1. Install Word Press 2.2.2 (which was the available version at Lunnarpages.com) 2. Drop in any Word Press theme that has a Contact post. Try WP themes like Connections-10, Green bug 10 or Pro-sunset.

comment:3 @misty97 years ago

Same theme used to work just fine in Word Press 2.2. The same theme stopped working as soon as I had installed Word Press 2.2.2. If that is not a code bug, what is?

comment:4 @misty97 years ago

Contact pages should be made using the "Page" functionality of WordPress, not the "Post" functionality. It is intended for all >>posts to show up on your "home" view.

  1. If that is the case, All the Word Press themes out there are done incorrectly then? You could verify the Contact created as posts in hundreds of WP themes.
  1. Okay. All posts should show up on the Home view. Why doesn't Contact post show up in the Home view in Word Press 2.2?

comment:5 @Nazgul7 years ago

  • Component changed from General to Template
  • Keywords reporter-feedback added
  • Milestone set to 2.5
  • Priority changed from high to normal
  • Severity changed from blocker to normal

I still don't get what the issue is.

Word Press 2.2.2 lists unintended Contact post on to the existing Home page

Posts are meant to be shown on the Homepage. Why shouldn't this one?

  1. Drop in any Word Press theme that has a Contact post

Themes don't have posts, so what do you mean with this?

I also downgraded the severity and priority. This may be a very imported issue to you, but on the grander scale it's not that serious (no data loss, blog still works, first report, ...)

comment:6 @markjaquith7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I tested the Pro-Sunset theme and the Connections 1.0 theme. Neither added any posts or pages. That would be very strange behavior for a theme.

The Connections 1.0 theme has a "Contact" link hardcoded into header.php, but it doesn't go anywhere -- it is a dummy link intended to be edited by hand. Pro-Sunset contains no such link, and in fact the word "contact" is not mentioned once in all of the theme's files.

In your support forum post, you said:

I have created the Contact as a Post

Well that's your problem right there. You need to create a Page, not a Post. Posts show on your 'home' view. You don't want that. So use a Page.

comment:7 @misty97 years ago

The question is what Word Press did you test the themes? If in Word Press 2.2, of course, you won't see any problems.

Okay. Here are the links that help to understand the problem:

  1. No Contact post in Home view using WP 2.2:

http://stocktrends.skybluedot.com/wdp4_stocktrends/

  1. Contact post exists in Home view using WP 2.2.2 http://skybluedot.com/korean_celebrities/ (the link is subject to change though, I will try to leave the way it is for you to take a look at it)

By the way, if the Contact is made as a Page i.e 3, the web site would actually issue an error "Sorry, no posts matched your criteria." because the "?p=3#respond".

Let me know if you need other info.

comment:8 @misty97 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:9 @misty97 years ago

Well that's your problem right there. You need to create a Page, not a Post. Posts show on your 'home' view. You don't want >>that. So use a Page.

if the Contact is made as a Page i.e 3, the web site would actually issue an error "Sorry, no posts matched your criteria." because the "?p=3#respond". The Contact post triggers the form that is meant for users to input their name, email and etc, right? If the form can't come up because it is created as a Page instead of post, what is the purpose of the Contact post to begin with?

comment:10 @misty97 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I still don't understand why the same theme would behave differently in WP 2.2 and 2.2.2. There is a bug somewhere in your code.

I have removed the Contact post and create a Contact page and put the interactive form in that Contact page as a workaround. Closing the bug for now. Thanks.

comment:11 @Nazgul7 years ago

  • Keywords reporter-feedback removed
  • Milestone 2.5 deleted
Note: See TracTickets for help on using tickets.